Mapa de Estoque Excel Logística WMS – 2

Mapa de Estoque Excel Logística WMS – 2

Demonstraremos neste artigo como criar um mapa de estoque em Excel que auxilie a Logística a localizar produtos no estoque e problemas de alocação da mesma forma que um WMS.

Uma das coisas que torna o Excel uma ferramenta diferente é a possibilidade de obtermos o mesmo resultado de maneiras diferentes.

Foi exatamente o que aconteceu quando eu recebi um e-mail de um dos nossos ex-alunos com uma solução diferente para a solução apresentada no post Mapa de Estoque Excel Logística WMS.

Mapa de estoque dinâmico 2 - Logística WMS 1

Na planilha que ele enviou havia uma solução bastante diferente que usava também os slicers e montava o quadro de identificação da disposição dos produtos em estoque da mesma forma, além de algumas melhorias, como destacar o prédio e o nível quando houverem produtos neles.

Mapa de estoque dinâmico 2 - Logística WMS 2

Como pode ver a solução funciona da mesma forma que a que criamos no post que o originou:

Mapa de estoque Excel Logística WMS

A grande diferença está na fórmula e no método utilizado para a criação desta outra planilha.

Na versão anterior que eu criei havíamos construído a solução utilizando uma tabela do Excel e uma fórmula complexa matricial, que envolvia inclusive SUBTOTAL para somar apenas os itens filtrados na tabela original, conforme o filtro da segmentação de dados.

Veja a fórmula original:

{=SOMARPRODUTO(SE(Base!$B$2:$B$501=Estoque!$H8;SE(Base!$C$2:$C$501=Estoque!I$7;Base!$D$2:$D$501))*SUBTOTAL(3;DESLOC(Base!$A$2;LIN(Base!$A$2:$A$501)-LIN(Base!$A$2);)))}

Um tanto quanto extensa não é mesmo?

Apesar de ser uma solução que possa ser aplicada, a primeira opção utiliza matricial, o que também é muito legal, eu mesmo gosto muito de utilizar fórmulas deste tipo. Bem como o meu amigo Fernando Fernandes, veja este vídeo legal: Formatação condicional matricial relativa.

Mas, como eu disse no início deste post citando o MVP Excel João Benito, no Excel há vários caminhos para uma mesma solução, não havendo um portanto um caminho mais correto do que o outro, apenas um mais elegante ou que seja mais simples.

No caso da solução apontada pelo amigo Evaldo que nos enviou o e-mail, ele criou uma tabela dinâmica, na qual colocou nas linhas o número do nível e nas colunas colocou o prédio, ficando desta forma disposta a tabela:

Mapa de estoque dinâmico 2 - Logística WMS 3

Desta forma os slicers foram criados, da mesma forma como havíamos feito para a tabela, e depois na tabela de localização WMS foi utilizada a seguinte fórmula:

=SEERRO(SOMA(DESLOC(TD!$B$4;CORRESP($A4;TD!$A$5:$A$65000;0);CORRESP(Aux!B$3;TD!$C$4:$V$4;0);CONT.SE(TD!$A$5:$A$65000;Aux!$A4);1));0)

É uma fórmula não matricial, aonde são utilizadas as funções SOMA, DESLOC, CORRESP e CONT.SE para identificar e somar na tabela dinâmica os valores do endereço de prédio e nível.

Com base nesta solução, pensei que realmente é mais simples e ainda criei uma nova solução também utilizando tabela dinâmica, mas dispondo os dados de outra forma e retornando com um SOMASES os dados:

Mapa de estoque dinâmico 2 - Logística WMS 4

Veja que agora o prédio e o nível estão nas linhas e nos valores está a soma da quantidade de produtos.

Então para retornar os valores utilizamos a fórmula:

=SOMASES('TD (2)'!$AI:$AI;'TD (2)'!$AG:$AG;'Aux (2)'!B$3;'TD (2)'!$AH:$AH;'Aux (2)'!$A4)

Na fórmula utilizamos o SOMASES para somar os valores quando for daquele prédio e nível e também obtemos a solução da mesma forma que nos dois exemplos anteriores.

Você pode fazer o download das planilhas digitando o seu nome e e-mail na lista abaixo para receber gratuitamente nossa newsletter semanalmente, e se já for cadastrado não se preocupe pode se cadastrar e clicar no link que vai funcionar da mesma forma.

Baixe a planilha

Abraço

Marcos Rieper