PROCV Exato Passo à Passo

Procv Exato

Como fazer o procv exato passo à passo, é isso que você aprenderá neste artigo.

A busca exata de dados tem por finalidade retornar alguma informação única, como uma busca pelo ID do cliente e retornar o seu nome, endereço, cidade, UF ou CEP. Esta é a forma mais utilizada da função Procv.

Função Procv 1

No exemplo acima, temos uma busca de uma informação chave ID (5), que será consultada em um intervalo de dados (B14:J22), e retornada a coluna 4, de forma Exata 0. A sintaxe da função Procv ficou desta forma:

Sintaxe:   =PROCV(valor_procurado;matriz_tabela;núm_índice_coluna;[procurar_intervalo])

Exemplo: =PROCV(C7;B14:J22;3;0)

  1. valor_procurado: C7, o valor chave da planilha, ele deve ser único.
  2. matriz_tabela:  B14:J22, onde deve ser realizada a pesquisa, pode ser uma tabela, colunas ou um intervalo.
  3. núm_índice_coluna: 3, o número da coluna que irá ser retornada, sempre contando da esquerda para a direita.
  4. [procurar_intervalo]: 0 para definir que seja realizada uma busca exata, é obrigatório colocar 0, porque o padrão desta função é uma busca aproximada, que tem sua utilidade, mas em buscas como esta poderá gerar erros.

Em 4 passos:

  1. Defina o que será pesquisado:Função Procv Excel
  2. Defina onde será pesquisado:Função Procv Excel
  3. Qual coluna você quer retornar? veja que a coluna Nome é a terceira coluna na seleção, então coluna 3 na função
    Função Procv Excel
  4. Digite 0 ou Falso. Este parâmetro é muito importante, é ele que define que a sua pesquisa é exata, não retornando se não for encontrado exatamente o valor da busca.
    Função Procv Excel
  5. Como resultado temos o nome Ana, que é o mesmo que consta na ID 5 da nossa lista de pesquisa na terceira coluna.
    Função Procv Excel

Veja também outros artigos:

PROCV em planilhas diferentes

PROCV com vários resultados – mais do que uma chave

PROCX Excel como usar

Índice Corresp – Como utilizar

Download da planilha Procv Exato

Para o download do exemplo utilizado neste artigo preencha o seu nome e e-mail no formulário abaixo.

Baixe a planilha