PROCV no Excel. Aprenda Passo a passo

PROCV no Excel. Aprenda Passo à passo

Como usar a função PROCV no Excel, é o que aprenderá neste tutorial.

A função Procv é uma das funções mais conhecidas do Excel, porque tem o objetivo de pesquisar dados no excel dinamicamente.

Por exemplo: Digamos que você tenha o código de um cliente e gostaria de retornar o nome dele de uma outra tabela no Excel. Com o PROCV você poderá retornar este dado de forma simples.

Então resumindo à partir de uma chave única (código do cliente) a função retorna o endereço.

Descrição dos Parâmetros do PROCV

O PROCV possui apenas 4 parâmetros:

PROCV(valor_procurado; matriz_tabela; núm_índice_coluna; [intervalo_pesquisa])

  1. valor_procurado: Valor que será procurado na outra lista. No nosso exemplo você colocaria a referência ou o valor do código do cliente.
  2. matriz_tabela: Local aonde irá buscar os dados, por exemplo uma lista com os códigos e nomes dos clientes da empresa.
  3. núm_índice_coluna: Número da coluna que deseja retornar. Digamos que a sua tabela com os nomes dos clientes da empresa tenha 2 colunas, a primeira tem o código do cliente e a segunda tem o nome. Então você digitaria 2 para retornar a segunda coluna.
  4. [intervalo_pesquisa]: Tem duas opções Exata ou Aproximada. No nosso caso estamos procurando uma situação de busca Exata, pois queremos exatamente o valor do código do cliente. Clique em PROCV Aproximado para saber como usar também o aproximado.

PROCV passo-a-passo

Seguindo o nosso exemplo, digamos que você esteja precisando pesquisar o nome do cliente à partir do seu código e este dado está em outra tabela.

Então para preencher a função do PROCV basta seguir essas 4 etapas:

Função Procv 1

O que procurar? Valor_procurado

Fórmula parcial =PROCV(C7

No primeiro parâmetro da função PROCV você irá selecionar o código do cliente que deseja procurar o nome na lista. Por exemplo o código é 5.

PROCV no Excel Aprenda Passo a passo

Onde procurar? matriz_tabela

Nesta etapa você irá selecionar a lista ou tabela aonde estão os dados, pode também selecionar as colunas inteiras. A única condição é que o Valor_Procurado precisa estar antes da coluna pesquisada, porque a primeira coluna selecionada é a coluna da busca.

Fórmula parcial: =PROCV(C7;B14:D3014

Portanto, para este parâmetro selecione os dados da procura aonde será pesquisado, comece selecionando a coluna que contém o código do cliente, esta tem que ser a primeira e selecione até aonde precisa.

PROCV no Excel Aprenda Passo a passo 2

Perceba que foi selecionado B14 à D3014, mas poderia selecionar também a tabela ou mesmo selecionar B:D, funcionaria da mesma forma.

O que retornar? núm_índice_coluna

Informe o número da coluna no intervalo que pretende retornar. Ela começa à contar sempre da primeira coluna da esquerda para as colunas da direita. Atenção, pois não é a coluna relacionada ao Excel e sim a coluna á contar da primeira.

Fórmula parcial: =PROCV(C7;B14:D3014;3

No nosso exemplo queremos retornar a 3.ª coluna, ou seja a coluna com o nome na nossa lista, por isso contamos aonde está esta coluna contando à partir do código(ID) do cliente e digitamos 3.


PROCV no Excel Aprenda Passo a passo 3

Esta busca é exata? [intervalo_pesquisa]

Na maioria das vezes você irá buscar o resultado Exato. Isso porque você precisará retornar um dado apenas se encontrar exatamente a informação pesquisada.

No nosso exemplo estamos pesquisando o nome do cliente com base no seu código e o código é único, não se repete.

Fórmula completa =PROCV(C7;B14:D3014;3;0)

Neste caso usamos o parâmetro 0, que é o mesmo que usar FALSO para uma busca aproximada.

 

Resultado da função

Nós precisávamos que fosse retornado o nome do cliente que está na terceira coluna, foi exatamente o que foi retornado.

Fórmula completa =PROCV(C7;B14:D3014;3;0)

PROCV no Excel Aprenda Passo a passo 5

Veja como a informação foi retornada automaticamente para a sua fórmula.

Erro no PROCV #N/D

Se a função não encontrar nenhum item ele irá dar um erro #N/D, pois ele significa Não Disponível, ou seja, não encontrado.

PROCV no Excel Aprenda Passo a passo 6

Isso aconteceria por exemplo se o código pesquisado pelo PROCV não estivesse na lista.

Para não exibir este #N/D na fórmula do PROCV use a função SEERRO()

PROCV no Excel Aprenda Passo a passo 7

No exemplo colocamos “NÃO ENC.” como a mensagem na função SEERRO e colocamos no começo da fórmula.

Fórmula: =SEERRO(PROCV(C7;B14:D3014;3;0);”NÃO ENC.”)

Assim temos um tratamento do erro para evitar este problema.

PROCV no Excel Aprenda Passo a passo 8

Outras dúvidas

Como fazer PROCV no Excel?

Ao longo deste artigo nós demonstramos detalhadamente como fazer o PROCV no Excel

Mas ele se resume em 4 passos:

  1. Selecione o que irá pesquisar. =PROCV(Código do cliente
  2. Selecione aonde irá pesquisar a informação. =PROCV(Código do cliente;Lista com os dados
    Importante: A primeira coluna deve ter o código do cliente, pois esta é utilizada para a busca.
  3. Digite o número da coluna que deseja retornar, por exemplo 3. =PROCV(Código do cliente;Lista com os dados;Número da coluna à partir da primeira
  4. Digite 0, este último parâmetro é para uma busca exata como é o caso do nosso exemplo. =PROCV(Código do cliente;Lista com os dados;Número da coluna à partir da primeira;0)

Pra que serve o PROCV?

Esta é uma função que tem a finalidade de realizar pesquisar verticais, de cima pra baixo, retornando informações de alguma coluna da lista de pesquisa.

Veja também no site da Microsoft.

Como usar o PROCV em outra planilha?

Os passos são semelhantes aos que apresentamos ao longo do artigo, pois a única diferença é que você deve selecionar a lista em outra planilha.

Quando estiver selecionando a lista clique na planilha que deseja buscar os dados e selecione a lista, da mesma forma que citamos anteriormente.

Erro #N/D no Procv como resolvo?

O erro de #N/D é referente à não disponível no Excel pois ele pode aparesentar este erro se não localizar a informação pesquisada.

Para resolver digite o código na lista aonde estão sendo pesquisados os dados ou caso ele realmente não exista use a função SEERRO, como demonstrado neste mesmo artigo.

Procv em inglês

A função Procv em inglês é VLOOKUP, a sequência dos parâmetros é a mesma dos que descrevemos.

Veja também no site da Microsoft.

Veja também outros artigos:

PROCV em planilhas diferentes

PROCV com vários resultados – mais do que uma chave

PROCX Excel como usar

Índice Corresp – Como utilizar

Download da planilha

Para o download do exemplo utilizado neste artigo preencha o seu nome e e-mail no formulário abaixo.

Baixe a planilha