Somar valores por mês Excel. Função SOMARPRODUTO Excel.

Conectando-se com o servidor proxy store.office.com - Excel 2013
Conectando-se com o servidor proxy store.office.com – Excel 2013
17 de dezembro de 2014
Dividir texto entre colunas usando funções - função Split Excel VBA
Dividir texto entre colunas usando funções – função Split Excel VBA
5 de janeiro de 2015

Objetivo: Demonstrar como somar valores por mês no Excel. Função SOMARPRODUTO Excel.

Somar por mês Excel 1

Ás vezes a disposição dos dados em formato de lista não nos fornece uma visão rápida da situação geral. Por exemplo qual foi o faturamento mensal de uma empresa.

No nosso exemplo temos uma lista com as vendas realizadas diariamente durante o ano de 2014 e queremos resumi-las em vendas mensais.

Para isso criamos uma lista auxiliar com o mês e fixamos os valores de 1 á 12 representando os meses.

Somar por mês Excel 2

Na célula F2 do nosso exemplo incluiremos a seguinte função e arrastaremos para as demais células

=SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*($B$2:$B$366))

Agora vamos entender a fórmula:

Conforme a Microsoft “Multiplica os componentes correspondentes nas matrizes fornecidas e retorna a soma destes produtos.“. Fonte: http://office.microsoft.com/pt-br/excel-help/somarproduto-HP005209293.aspx. A função SOMARPRODUTO tem por finalidade realizar a soma de valores conforme condições determinadas em sua fórmula. Por exemplo, somar todos os valores quando o mês for 1.

Na função colocamos que para todas as células aonde o mês for igual ao definido na célula E2: (MÊS($A$2:$A$366)=E2) devem ser somados os valores da lista *($B$2:$B$366)Como a função SOMARPRODUTO é matricial, ou seja, recebe várias listas de parâmetros e compara os valores com outra lista, como no exemplo, somar uma lista quando for atendida uma condição em outra lista, o sinal de *utilizado normalmente para multiplicação dentro do Excel, assume a função de identificar que as duas listas estão relacionadas.

Este é apenas um exemplo, neste outro artigo http://guiadoexcel.com.br/somarproduto á um exemplo mais complexo, utilizando a mesma função SOMARPRODUTO, neste outro exemplo são utilizados várias condições para a soma.

Apenas para conhecimento a função SOMASES também realiza a mesma função na maioria dos casos, exceto quando há a necessidade de aplicação de fórmulas para as condições, como é o caso do nosso exemplo, em que é utilizada a função MÊS.

O nosso exemplo completo fica assim:

Somar por mês Excel 3

Faça o download do nosso exemplo clicando no botão abaixo.

GUT PPT

Quer aprender Excel Avançado ou Excel VBA? Conheça os nossos cursos, os melhores do mercado a preços baixíssimos e garantia de aprendizado. Cursos Guia do Excel.

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/

17 Comentários

  1. Wilson Munhoz disse:

    Excelente artigo. Me ajudou bastante.
    Obrigado.
    Sds, Wilson Munhoz

  2. Carla Tiago disse:

    Olá,

    Usando as mesmas células e referências do seu exemplo, eu gostaria de saber como eu poderia calcular não só as informações referente ao mês mas também o ano e daí sim fazer o somatório.

    Eu tentei algo nesse sentido mas não consegui chegar numa conclusão:

    =SOMARPRODUTO(MÊS($A$2:$A$16)=MÊS(AGORA());ANO($A$2:$A$16)=ANO(AGORA())*($B$2:$B$16))

    Preciso muito de resolver essa questão para uma planilha no meu trabalho que precisa somar valores do mês atual.

    Ficarei muito agradecida se puder me auxiliar.

    Carla.

    • Marcos Rieper disse:

      Boa noite Carla,

      Julgando que na célula E2 temos o mês e na célula D2 temos o ano, temos a seguinte função que resolve o seu problema. =SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*(ANO($A$2:$A$366)=D2)*($B$2:$B$366)).

      Pode baixar a planilha do artigo e colocar esta função no lugar da que consta nela, apenas digite no camop D2 o valor 2014.

      Abraço

      Marcos Rieper

  3. Renato disse:

    Excelente explanação. Obrigado por resolver meu problema.

  4. Bruno disse:

    Olá, boa tarde!

    Eu preciso de um código, que atenda a mesma necessidade acima (some valores por Mês, Ano e outro critério), porém para o VBA. Você teria como me ajudar?

  5. Robs disse:

    ótima dica!!!

  6. MARCELO disse:

    Poderia me ajudar. tenho uma planilha com seguinte criterio
    COLUNA A COLUNA B COLUNA C
    DATA VALOR PROCEDIMENTOS
    16/03/2017 R$ 718,00 AMBULATÓRIO – EXAMES
    16/03/2017 R$ 1.309,00 AMBULATÓRIO – EXAMES LABORATÓRIO
    16/03/2017 R$ 54,00 AMBULATÓRIO – CONSULTA
    16/03/2017 R$ 54,00 AMBULATÓRIO – CONSULTA
    16/03/2017 R$ 54,00 AMBULATÓRIO – CONSULTA
    16/03/2017 R$ 54,00 AMBULATÓRIO – CONSULTA
    16/03/2017 R$ 460,00 ADAPTAÇÃO DE LENTES DE CONTATO
    18/03/2017 R$ 54,00 AMBULATÓRIO – EXAMES
    18/03/2017 R$ 38,00 AMBULATÓRIO – EXAMES LABORATÓRIO
    18/03/2017 R$ 98,00 AMBULATÓRIO – CONSULTA
    18/03/2017 R$ 25,00 AMBULATÓRIO – CONSULTA
    18/03/2017 R$ 460,00 AMBULATÓRIO – CONSULTA
    18/03/2017 R$ 718,00 AMBULATÓRIO – CONSULTA
    18/03/2017 R$ 1.309,00 ADAPTAÇÃO DE LENTES DE CONTATO

    VALORES PROCEDIMENTOS DO DIA 16/03/2017
    AMBULATÓRIO – EXAMES R$ 0,00
    AMBULATORIO – CONSULTA R$ 0,00
    CENTRO CIRUGICO – CIRURGIAS R$ 0,00
    ADAPTAÇÃO DE LENTES DE CONTATO R$ 0,00
    AMBULATÓRIO – EXAMES LABORATÓRIO R$ 0,00
    Total Geral no Dia R$ 0,00

    PRECISO INFORMAR A FORMULA NO QUADRO RESUMO ONDE SOMAR TODOS OS PROCEDIMENTOS POR DIA. O UNICO CAMPO QUE DEVO INFOMAR MANUAL SERIA O DIA DO MES QUE QUERO SABER

    • Jonas de Sena Grippa disse:

      Boa tarde amigo

      =SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*($B$2:$B$366))

      No caso dessa fórmula, você selecionaria para colocar aqui “((MÊS($A$2:$A$366)”, da coluna A até a linha do “18/03/2017 R$ 1.309,00 ADAPTAÇÃO DE LENTES DE CONTATO” e aqui “($B$2:$B$366))” todas as linhas e colunas com os valores que você quer considerar, para o resultado sair você deve colocar um número de referência para o mês no “=E2)” da fórmula (Ex=1 para janeiro ou 2 para fevereiro e por ai vai)

  7. Rui Silva disse:

    Bom Dia,
    Gostaria que pudessem dar uma ajuda numa questão.
    Tenho uma tabela onde por ex: uma coluna tenho inseridas datas e tenho uma outra coluna onde a cada data corresponde a uma valor, preciso encontrar uma formula que atraves da data faça a soma dos valores por mes.

    cumps
    Rui Silva

  8. Wilson Delgado disse:

    Muito bom !!! Consegui encontrar a formula que precisava sem rodeios e com eficácia!!!

  9. Carlos Matiolo disse:

    Eu tenho uma planilha para controle de orçamentos, faço contagem de pedidos por mês e seus respectivos valores. Estou com um problema para a contagem do mês de Janeiro, minha planilha está sem dados e a célula do mês de janeiro está dando 908, mas deveria dar 0.
    Abaixo as formular que eu estou usando:

    Está errado – Janeiro: =SOMARPRODUTO((MÊS($C$35:$C$942)=1)*1)
    Está certo – Fevereiro: =SOMARPRODUTO((MÊS($C$35:$C$942)=2)*1)

    E quando eu coloco a data que chegou pedido ele conta, porem para janeiro não está acontecendo

    Onde estou errando?

  10. EMERSON BATISTA disse:

    ÓTIMO, MUITO BOM! OBRIGADO!

  11. Welison disse:

    Como ficaria no caso para se fazer a média??

    • Marcos Rieper disse:

      Boa tarde Welison,

      Neste caso use a função: =SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*($B$2:$B$366))/SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*1)

      Abraço
      Marcos Rieper

  12. Gilberto disse:

    Marcos, preciso de algo semelhante a isso, em uma planilha tenho diversas semanas (a planilha tem semanas referente a 2 anos), cada semana tem um valor de meta a ser utilizado, eu preciso de uma formula que faça o acumulado das semanas que passaram, somando c/ a semana atual, que seja naquele sistema que o excel some as semanas anteriores com a data de hj e me dê um acumulativo
    Ex: de Jan/2018 até hj (01/08/18) quanto seria, sendo que nestas mesma celula tem por exemplo um valor de 1000 a ser usado durante o ano de 2018, mas só passou 8 meses. Então destes 1000, quanto deveria ter usado até hj

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.