Somar valores por mês Excel. Função SOMARPRODUTO Excel.

Objetivo: Demonstrar como somar valores por mês no Excel. Função SOMARPRODUTO Excel.

Somar por mês Excel 1

Ás vezes a disposição dos dados em formato de lista não nos fornece uma visão rápida da situação geral. Por exemplo qual foi o faturamento mensal de uma empresa.

No nosso exemplo temos uma lista com as vendas realizadas diariamente durante o ano de 2014 e queremos resumi-las em vendas mensais.

Para isso criamos uma lista auxiliar com o mês e fixamos os valores de 1 á 12 representando os meses.

Somar por mês Excel 2

Na célula F2 do nosso exemplo incluiremos a seguinte função e arrastaremos para as demais células

=SOMARPRODUTO((MÊS($A$2:$A$366)=E2)*($B$2:$B$366))

Agora vamos entender a fórmula:

Conforme a Microsoft “Multiplica os componentes correspondentes nas matrizes fornecidas e retorna a soma destes produtos.“. Fonte: http://office.microsoft.com/pt-br/excel-help/somarproduto-HP005209293.aspx. A função SOMARPRODUTO tem por finalidade realizar a soma de valores conforme condições determinadas em sua fórmula. Por exemplo, somar todos os valores quando o mês for 1.

Na função colocamos que para todas as células aonde o mês for igual ao definido na célula E2: (MÊS($A$2:$A$366)=E2) devem ser somados os valores da lista *($B$2:$B$366)Como a função SOMARPRODUTO é matricial, ou seja, recebe várias listas de parâmetros e compara os valores com outra lista, como no exemplo, somar uma lista quando for atendida uma condição em outra lista, o sinal de *utilizado normalmente para multiplicação dentro do Excel, assume a função de identificar que as duas listas estão relacionadas.

Este é apenas um exemplo, neste outro artigo http://guiadoexcel.com.br/somarproduto á um exemplo mais complexo, utilizando a mesma função SOMARPRODUTO, neste outro exemplo são utilizados várias condições para a soma.

Apenas para conhecimento a função SOMASES também realiza a mesma função na maioria dos casos, exceto quando há a necessidade de aplicação de fórmulas para as condições, como é o caso do nosso exemplo, em que é utilizada a função MÊS.

O nosso exemplo completo fica assim:

Somar por mês Excel 3

Faça o download do nosso exemplo clicando no botão abaixo.

GUT PPT

Quer aprender Excel Avançado ou Excel VBA? Conheça os nossos cursos, os melhores do mercado a preços baixíssimos e garantia de aprendizado. Cursos Guia do Excel.

Abraço

Marcos Rieper