Contar Valores Distintos Excel, Somar Valores Distintos Excel

Objetivo: Demonstrar como contar ou somar valores distintos no Excel.

Uma tarefa que pode ser realizada utilizando funções auxiliares é a de contar ou somar valores distintos, porém com as funções CONT.NÚM ou SOMA e o uso das funções SE e FREQUÊNCIA temos o mesmo resultado de uma forma bem mais elegante e com menos esforço.

Para a função de Contagem de distintos utilize a função: =CONT.NÚM(SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;A4:A18)) aonde A4:A18 é o intervalo que será testado.

Para a função de Soma de distintos utilize a função: =SOMA(SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;B4:B18)) aonde os primeiros dois intervalos A4:A18 são referentes a seqüência a ser testada e o último ao intervalo a ser somado quando a coluna anterior for distinta, no caso é utilizada a mesma.

Baixe a planilha

Abraço

Marcos Rieper