Contar Valores Distintos Excel, Somar Valores Distintos Excel

Veja como contar valores distintos e como somar valores distintos no Excel.

No nosso exemplo temos uma lista com a quantidade de notas fiscais e valores distintos, ou seja, sem repetição.

Contar Valores Distintos Excel

Uma tarefa que pode ser realizada utilizando funções auxiliares é a de contar ou somar valores distintos, porém com as funções CONT.NÚM ou SOMA e o uso das funções SE e FREQUÊNCIA temos o mesmo resultado de uma forma bem mais elegante e com menos esforço.

Para a função de Contagem de distintos utilize a função: =CONT.NÚM(SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;A4:A18)) aonde A4:A18 é o intervalo que será testado.

  • FREQÜÊNCIA(matriz_dados; matriz_bin): Esta função realiza a verificação da quantidade de vezes que um número é repetido em uma matriz de dados binária.
    O primeiro parâmetro é aonde iremos consultar os dados e o segundo parâmetro é o que iremos pesquisar.
    O retorno é a quantidade de vezes que cada um dos itens da matriz_bin ocorre na lista de dados.
    Temos então o seguinte retorno da função Freqüência: {3;0;2;0;2;0;1;1;1;1;1;1;0;1;1;0}, veja que retorna então a quantidade de vezes 3 vezes, 0 vezes, 2 vezes, etc. ele só mostra a primeira vez que ocorreu.
  • SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;A4:A18): é verificado se o valor é maior do que 0 e se for então retorna o número: {123;FALSO;124;FALSO;157;FALSO;56;70;71;72;73;175;FALSO;154;156;FALSO}
    Veja que são retornados então o número da nfe ou senão retorna FALSO.
  • CONT.NÚM(SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;A4:A18)): Esta função conta os números da matriz retornada pela função Se e Frequência. Contando então somente as que ocorreram mais do que 0.

Somar Valores Distintos Excel

Para a função de Soma de distintos utilize a função: =SOMA(SE(FREQÜÊNCIA(A4:A18;A4:A18)>0;B4:B18)) aonde os primeiros dois intervalos A4:A18 são referentes a seqüência a ser testada e o último ao intervalo a ser somado quando a coluna anterior for distinta, no caso é utilizada a mesma.

Veja que a fórmula é praticamente igual a de contar valores distintos no Excel.

A função funciona da mesma forma porque o retorno da função se é: {433;FALSO;433;FALSO;341;FALSO;407;428;126;263;158;332;FALSO;315;412;FALSO}

Então temos a soma apenas dos totais das notas fiscais sem repetir o total.

Esta somando apenas pela primeira ocorrência do número da nota fiscal, a única necessidade é que as colunas tenham a mesma quantidade de registros na matriz.

Download Planilha Distintos no Excel

Realize o download da planilha de download para contar e somar valores distintos no Excel neste botão abaixo. Basta se inscrever na nossa newsletter gratuita para o download automático.

Baixe a planilha