Filtro de Dados Utilizando CheckBox e VBA

Recibo em Excel e VBA
Recibo em Excel e VBA
27 de março de 2011
Tabela de Campeonato de Futebol Excel
Tabela de Campeonato de Futebol Excel
1 de abril de 2011

Objetivo: Demonstrar o uso de filtros de dados utilizando objetos combobox e VBA.

Este tutorial foi enviado pelos amigos Michele Soares e Renato Morais de São Paulo/SP, obrigado pelo ótimo material.



//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.

 

1 – Nas células P3, P4 e P5, atribuir a fórmula condicional “SE” para Identificar o Estado caso ele seja desmarcado.

Coluna Fórmula
P3 =SE(O3=VERDADEIRO;””;N3)
P4 =SE(O4=VERDADEIRO;””;N4)
P5 =SE(O5=VERDADEIRO;””;N5)

2 – Na célula P6, concatenar os valores de P3,P4 e P5, a fim de formar uma única string com todos os estados desmarcados.

Coluna Fórmula
P6 =CONCATENAR(P3;P4;P5)

3 – Na aba “Desenvolvedor”, clicar no botão “Macro”, para criar uma nova macro.

4 – Na janela de controle da macro, digitar o nome atribuído a macro, neste caso “FiltraUF”, e clicar no botão “Criar”.

5 – Utilizar o código VBS implementado na macro. Quando acionada a macro, esse código varrerá da linha 9 até a 22, verificando se os estados cadastrados na coluna “D” estão presentes na célula “P6”. Caso o estado esteja presente, a linha será ocultada pelo comando hidden. Se o estado não estiver presente, será atribuído false ao comando hidden para reabilitar a linha. O código também executa a soma dos valores das 3 colunas (“Áudio/Video”, “Telefonia”, “Informática”) apenas para as linhas visíveis e disponibiliza o resultado nas células “G24”, “I24” e “K24”.

6 – Para que a macro seja processada a cada contato com o checkbox, ela deverá ser associada ao evento. Para isso, clicar com o botão direito em cada item do checkbox e selecionar a opção “Atribuir Macro…”

7 – Na caixa de seleção, escolher a macro “FiltraUF” e clicar em “OK”.

8 – Pronto, o filtro de informações por estado via macro está concluído!

Muito obrigado pela colaboração de vocês Michele e Renato, e quem quiser participar enviando planilhas e tutoriais estamos aqui para dividir conhecimento.

 

 

 

 

Arquivo Excel

Arquivo Excel

Tutorial

Tutorial

Abraço

Marcos Rieper

//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.

 


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/

1 Comentário

  1. Gilberto disse:

    Boa noite! Estou usando o Office 2010 e baixei esse arquivo para entender o processo proposto, e juro que não entendi, desculpe minha pouca experiência, mas qual o fundamente desta planilha??? Gostaria de utilizá-la

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.