Contar e Somar Condicional utilizando Somarproduto Excel

Contar e Somar Condicional utilizando Somarproduto Excel

Objetivo: Demonstrar a utilização da função Somarproduto na contagem e soma condicional de valores, com a vantagem de não ser necessário abrir a planilha base para atualizar os dados.

Contribuição: Este artigo foi enviado pelo amigo Samuel Suzini, ao qual agradeço pela contribuição.

 A função somarproduto no Excel realiza uma ação de multiplicação entre duas listas de dados.

Estas listas de dados tem que ter o mesmo tamanho e podem ser condicionadas a algum valor como é o caso do nosso exemplo aonde são somadas as quantidades vendidas por linha e vendedor e também o valor total do faturamento de cada venda por linha e vendedor.

Estas ações podem ser feitas também com o uso do cont.se e do somase, porém com a diferença de que se você estiver buscando os dados de outro arquivo, não será necessário abrir este outro arquivo, o que seria o caso na utilização destas duas funções.

Função de contagem condicional excel

1. A função utilizada na contagem foi =SOMARPRODUTO((GERAL!$B$2:$B$199=RESUMO!B2)*(GERAL!$D$2:$D$199=RESUMO!E2)) aonde temos:

 a. GERAL!$B$2:$B$199 -> matriz dos vendedores que efetuaram cada venda;

 b. =RESUMO!B2 -> esta cláusula na função faz com que sejam retornados da lista GERAL!$B$2:$B$199 apenas os valores que sejam iguais ao código do vendedor que consta nesta célul;

  c. * -> a multiplicação determina que os dados cujo o resultado da comparação seja alcançado sejam multiplicados pela quantidade na segunda comparação;

 d. GERAL!$D$2:$D$199=RESUMO!E2 -> Retorna o resultado da coluna D da planilha Geral aonde os dados sejam dos departamentos constantes em Resumo!E2.

Função de soma condicional excel

1. Na função de soma condicional utilizada foi =SOMARPRODUTO((GERAL!$B$2:$B$199=RESUMO!B2)*(GERAL!$D$2:$D$199=RESUMO!E2)*(GERAL!$C$2:$C$199)) aonde temos as mesmas condições anteriores, com a diferença da última parte aonde multiplica-se os itens que atendem os critérios pela coluna de valor da venda.

 a. GERAL!$B$2:$B$199 -> matriz dos vendedores que efetuaram cada venda;

 b. =RESUMO!B2 -> esta cláusula na função faz com que sejam retornados da lista GERAL!$B$2:$B$199 apenas os valores que sejam iguais ao código do vendedor que consta nesta célul;

 c. * -> a multiplicação determina que os dados cujo o resultado da comparação seja alcançado sejam multiplicados pela quantidade na segunda comparação;

 d. GERAL!$D$2:$D$199=RESUMO!E2 -> Retorna o resultado da coluna D da planilha Geral aonde os dados sejam dos departamentos constantes em Resumo!E2.

 e. *(GERAL!$C$2:$C$199)) -> Esta última parte realiza a multiplicação dos valores que atendem os critérios pelo valor de faturamento de cada venda.

Abaixo você pode baixar o arquivo enviado pelo Samuel.

GUT PPT

Abraço

Marcos Rieper