Guia do Excel em outros idiomas
Guia do Excel em outros idiomas
18 de julho de 2011
Gráfico de Excel de Análise de Faturamento
Gráfico de Excel de Análise de Faturamento
22 de julho de 2011

Objetivo: Demonstrar a utilização da função somarproduto do Excel.


Agradecimento a leitora Myrian Campos Trindade que sugeriu o tema deste artigo.

A função somarproduto tem por finalidade realizar a soma de valores conforme condições determinadas em sua fórmula. Por exemplo, somar todos os valores quando o vendedor for José, o cliente for TOMSP e o mês for 2010/1. Ela é utilizada da seguinte forma: =SOMARPRODUTO(-(A:A=I3);-(B:B=J3);-(G:G=K3);(E:E)) Sendo:

  1. os primeiros parâmetros -(A:A=I3);-(B:B=J3);-(G:G=K3); as condições que se diferenciam do campo a ser somado pelo sinal de negativo antes das mesmas.
  2. O parâmetro (E:E) cujo o campo será somado. Ele não possui o sinal negativo antes.

Entendendo as condicionais: A primeira e a segunda condicional fazem menção ao valor específico de uma célula. No caso o valor da célula I3 na primeira condição é José. A passagem do parâmetro -(A:A=”José”), significa na primeira parte A:A o intervalo que será verificado e na segunda parte =”José” o campo que será procurado nesta lista. Esta condição foi passada como =, porém podem ser utilizadas outros operadores como > e <, verificando por exemplo os valores entre 100 e 500. Neste site, http://doutorexcel.wordpress.com/2011/03/01/analise-de-resultados-indireto-somarproduto-e-somase/ tem uma planilha com um exemplo também bastante interessante de como utilizar esta e outras funções combinadas.

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/
Cursos

Curso Excel Completo – Curso Excel Básico + Curso Excel Avançado – Acesso Vitalício

R$218,00 R$179,00

COMPRAR
Cursos

Curso Excel Master – Curso Excel Básico + Curso Excel Avançado + Curso VBA Excel + LP – Acesso Vitalício

R$357,00 R$249,00

COMPRAR
Cursos

Curso Excel PRO – Curso Excel Avançado + Curso VBA Excel + Lógica de programação – Acesso Vitalício

R$258,00 R$199,00

COMPRAR
Cursos

Curso Excel Web – Curso VBA Excel + Lógica de programação + Curso Web Scraping VBA- Acesso Vitalício

R$388,90 R$309,00

COMPRAR

11 Comentários

  1. Walter Bernal disse:

    Olá Marcos,

    Bacana a formula, porém se usarmos a formula “SOMASES” também possui o mesmo resultado.

    EX: =SOMASES(E:E;A:A;I3;B:B;J3;G:G;K3)

    Fiz o teste e surti o mesmo efeito, ou existe alguma coisa nessa formula que não funcionaria igual em outra circunstância?

    Abraço!

  2. Walter Bernal disse:

    No campo total…

  3. Myrian disse:

    Olá!
    Marcos, obrigada por postar minha sugestão.
    Bom… acredito que para considerar a soma somente de valores maiores que 100 E menores que 500 a fórmula correta na célula K5 seja: =SOMARPRODUTO(-(E:E>100);-(E:E100) e por isso o valor está
    -99.017,30.
    … A menos que a intenção da formula usada (=SOMARPRODUTO(-(E:E>100)-(E:E100 (resultado=43.579,03)
    mais
    aos valores que na coluna E sejam menores que 500 (resultado=55.438,27).
    E considerar com sinal negativo. (por causa do sinal negativo… poderia ter sido usado +
    ou — (dois sinais de menos juntos)… e o resultado seria com o sinal correto em qualquer situação).
    Reparem que neste caso, poderia se fazer o filtro pela coluna E e somar os respectivos valores da coluna D por exemplo… (como no somases) e o valor seria 1.855.307.

    Sobre o questinonamento do Walter, observei algumas vantagens em relação ao somases:
    1) ocupa menos memória;
    2) maior facilidade para filtros mais detalhados, como por exemplo, filtrar palavras que começam com J, pode-se usar a condição “J*”, sem necessidade de qualquer outra fórmula (localizar, direita, esquerda, extrair, etc);
    3) Substituir fórmulas matriciais;
    4) Grande alternativa para quem não tem o excel superior a 2003 e não tem a alternativa de somases, somente o somase.

    Abraços de bom final de semana!

  4. Myrian disse:

    Faltou escrever o resultado da fórmula =SOMARPRODUTO(-(E:E>100);-(E:E<500);(E:E))
    = 34.074,61
    e lugar de -99.017,30.

  5. Linelson Y Castro disse:

    Não sabia que somarproduto podia ser usada nesse caso. Mas só funciona pq só há uma coluna de valores, certo? Pq precisa colocar – (menos) antes de cada matriz ?

    Para ficar o resultado certo (positivo), deve-se usar – – (dois menos).

    • Marcos Rieper disse:

      Boa noite Linelson,

      Os parâmetros passados como – são as verificações realizadas, e o último a coluna a ser somada.

      Os parâmetros não necessariamente precisam ser colunas de valor, mas a coluna de soma sim.

      O – portanto é somente para distinguir os parâmetros da matriz a ser somada, não tendo a ver com o sinal da soma.

      Abraço

      Marcos Rieper

  6. […] é apenas um exemplo, neste outro artigo http://guiadoexcel.com.br/somarproduto á um exemplo mais complexo, utilizando a mesma função SOMARPRODUTO, neste outro exemplo são […]

  7. Olá!

    E se eu quiser usar um somarproduto condicionado a um OU outro valor? Por exemplo, tenho esta tabela e quero fazer um preço ponderado para produtos específicos, ele só deve considerar valores quando os produtos forem “Prego” ou “Martelo”.

    PRODUTO QTDE PREÇO

    Prego 5 8
    Martelo 7 20
    Tinta 7 40

    tentei: =SOMARPRODUTO(-(OU(B9:B11=”Prego”;B9:B11=”Martelo”));(C9:C11);-(OU(B9:B11=”Prego”;B9:B11=”Martelo”));(D9:D11)) mas não funcionou..

    Alguém pode ajudar, por favor?
    Grato!

  8. Marcelo Ribeiro Simões disse:

    Olá Marcos,
    Estou procurando solução para minha pretensa planilha de “controle de vendas e comissões”.
    Preciso da ajuda de alguém que entenda como montar isso direito porque não tenho mais idéias pelo meu curto conhecimento de Excel.

    O objetivo é saber o quanto tenho para receber em um determinado mês fazendo que o Excel encontre todas as parcelas de cada venda que coincidem com cada mês.

    Por exemplo, no mês de fevereiro fiz algumas vendas.
    Umas pagaram à vista, outras em 3 parcelas iguais.
    É óbvio que a venda à prazo fragmentou o pagamento não somente em valores mas em espaço de tempo.

    Fiz colunas e linhas que trabalham com isso, mas fiquei empacado no momento de finalizar o raciocínio para me mostrar quanto cada parcela que será paga no mesmo mês resulta no total.

    São muitos faturamento à prazo desde fevereiro até agora e preciso começar a ter certo tipo de controle do que tenho para receber.

    Caso tenha ficado qualquer dúvida e tenha interesse em me ajudar, por favor, entre em contato.
    Posso enviar a planilha que estou montando para que possa entender melhor.

    Cada Tabela representa um mês.
    Coluna A tem a data da venda.
    Coluna B o nome da empresa cliente.
    Coluna C o fornecedor.
    Coluna D o valor total da venda
    A coluna D até a coluna H são os prazos de parcelamento (costumo colocar 28 na primeira, 56 na segunda, 84 na terceira e tenho a quarta para a excepcional forma de 4 parcelas).
    .Tenho uma coluna que eu preencho com o percentual de comissão de cada pedido e outra que calcula o valor da comissão.
    Tenho outra que divide a comissão pelo número de parcelas e outra que já calcula o dia do pagamento de cada parcela.

    O que me falta é entender como somar cada parcela de cada venda de modo que eu saiba o total a receber em cada mês.

    Espero ter sido claro.

    Agradeço desde já e aguardo seu retorno
    marcelo.anexa@gmail.com.

  9. Caroline disse:

    Boa noite, estou tentando usar a fórmula, porém o resultado só da zero. O que estou fazendo de errado?
    =SOMARPRODUTO(-(G2:G7=F2);-(H2:H7=F2))/SOMASE(F2:F7;F2;H2:H7)
    Pedra 8,33 1
    Pedra 5,45 20
    Pedra 6,51 7
    Tesoura 4,00 3
    Tesoura 6,00 5
    Tesoura 10,00 7

  10. Caroline disse:

    Não estou conseguindo. Só da zero o resultado. O que estou fazendo de errado?
    =SOMARPRODUTO(-(G2:G7=F2);-(H2:H7=F2))/SOMASE(F2:F7;F2;H2:H7)

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.