Compreendendo mensagens de erros em fórmulas Excel
Compreendendo mensagens de erros em fórmulas Excel
17 de março de 2014
Gráfico de distribuição por idade e gênero Excel
Gráfico de distribuição por faixa de idade e gênero Excel
31 de março de 2014

Objetivo: Demonstrar como criar gráficos de semáforo no Excel.

Semáforo ExcelNeste artigo vou apresentar passo-a-passo como criar um gráfico de semáforo, que na verdade não é nem um gráfico,  é montado somente com imagens.

Digite os dados da planilha abaixo neste formato:

Semáforo Excel 8

A primeira coluna indica somente a situação que temos para as metas.

Na coluna Meta temos a meta de valor que deve ser configurada conforme a sua  situação, a primeira indica a meta  mais alta que identifica o valor para verde no semáforo, amarelo recebe o valor subsequente e vermelho fica vazio, pois qualquer valor abaixo de 70 ficará vermelho no semáforo.

Para a coluna N, S, L ou O é colocado o valor que foi executado para cada região, as siglas estão identificando região norte, sul, leste e oeste.

Agora crie a estrutura seguinte:

Semáforo Excel 9

Esta estrutura fica somente em branco, altere o formato dos valores para a fonte Wingdings.

Digite a função =SE(C2>=$B$2;”l”;””) para a primeira célula da coluna N, aonde temos C2 o valor que foi executado para cada região e B2 o valor da meta, arraste para todos os valores das colunas da primeira linha.

Para a segunda linha da coluna N digite a função =SE(E(C2>=$B$3;C2<$B$2);”l”;””) que identifica se o valor está em amarelo, perceba que se estiver dentro do período ele preenche com a letra “l”, que na fonte Windgdings faz com que fique uma bolinha.

Para a terceira linha digite a fórmula =SE(C2<$B$3;”l”;””).

Agora que temos os dados, vamos ao gráfico de semáforo.

Desenhe em Inserir->Formas e selecione retângulo e crie um retângulo preto, conforme abaixo:

Semáforo Excel 2

Agora faça mais um retângulo com bordas e coloque sobre o  retângulo preto:

Semáforo Excel 3

Desenhe círculos coloridos em vermelho, amarelo e verde conforme a imagem abaixo, também usando  as ferramentas de desenho do Excel.

Semáforo Excel 4

Crie um retângulo com 32% de transparência, faça isso clicando com o botão direito sobre  o retângulo desenhado e em propriedades->Preenchimento->Preenchimento sólido, selecionar a cor preta e alterar a transparência para 32%, ficará conforme abaixo:

Semáforo Excel 5

Posicione esta imagem sobre  o semáforo:

Semáforo Excel 6

Teremos então um semáforo apagado. Agora desenhe caixas de texto sobre o vermelho, outra sobre o amarelo e outra sobre o verde.

Semáforo Excel 7Faça isso na guia Inserir->Caixa de Texto, e posicione um quadrado sobre cada um deles.

Agora para a primeira caixa de texto, selecione a mesma e depois clique em Função e digite =e selecione a célula G4 para vermelho, G3 para amarelo e G2 para verde.

Desta forma temos que toda a vez que a função tiver um valor atingido em Verde, Amarelo ou Vermelho o semáforo irá automaticamente mudar de cor.

DIGITE O SEU EMAIL PARA FAZER O DOWNLOAD DOS ARQUIVOS:

Abraço

Marcos Rieper

17 Comments

  1. Danilo disse:

    Olá, boa tarde. Detectei um equívoco, ao invés de utilizar para segunda linha a sintaxe: =SE(E(C2>=$B$3;C2<$B$2);”l”;”") [ pode ver que não funciona na planilha atual ] , substitui por: =SE(E(C2=B3);”l”;””) [ deixando a coluna G em branco ].

  2. Danilo disse:

    =SE(E(C2=B3);”l”;””) – Esqueça a fórmula anterior e considere esta.

  3. Tá faltando uma informação muito importante, veja que não é uma a Letra “I” Maiúscula meu caro Marcos, pois se colocar assim e virar font Wings vira um flor. Por favor tem como colocar a combinação para o símbolo correto?
    Agradeço.

  4. Meu caro, muito obrigado por sua atenção mas já descobri. O valor que deve ser digitado é Alt+108.
    Valeu riper e parabéns pelo trabalho de traduzir a aplicação, já que é de ordem americana. Valeu mesmo por compartilhar.
    Att,
    Jaime.

  5. Pedro Castro disse:

    Bom dia.

    Segui todos os passos certinhos até fazer a caixa de texto que indica. Mas nao estou a conseguir associar as caixas de texto com a função =e. Podia por favor especificar mais esse passo?

    Obrigado

  6. =SE(C2>=$B$3;SE(C2<$B$2;"l";"");"")
    A segunda linha referente ao amarelo, fiz com a seguinte fórmula e deu certo.

    Abraços

  7. Francine disse:

    Olá, muito bom o seu tutorial, mas está faltando uma informação, quando baixei a planilha que que tem um outro círculo dentro do primeiro que já havíamos inserido, que é justamente o que acende, mas aqui você não deixou este passo claro. Será que podia completar este passo? É possível? O meu não acende de jeito nenhum, e vi que é nisto que estou me perdendo…..

  8. Rafael disse:

    Marcos, boa tarde,
    Sensacional o seu exemplo.
    Bem simples

  9. Ivete Araujo disse:

    Onde está o Download no final da página? Pois não consigo inserir a função dentro da caixa de texto…

  10. Ivete Araujo disse:

    Marcos, obrigada pelo retorno.
    Estou com duas situações:
    1 – Após colocado a fórmula o que aparece dentro da caixa de texto da função é a “bolinha” vermelha, em vez de acender o farol.
    2 – não estou conseguindo agrupar os objetos.
    Como corrigir essas divergências?
    Agradeço desde já.

  11. mARCELO disse:

    oLA MUITO BOM

  12. mARCELO disse:

    Ola tudo bem.. muito bom o controle

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.