Cont.se – Função Excel

Planilha excel tipos de escala de trabalho CLT - Guia do Excel
Planilha para tipos de escala de trabalho permitidas CLT
24 de fevereiro de 2018
Conectar Excel no Google analytics capa - Guia do Excel
Como conectar o Google Analytics no Excel
10 de março de 2018
Função cont.se Excel

Cont.se – Função Excel

A função cont.se, no Excel, veja também: Cont.se cláusula contém tem por objetivo contar as células de um intervalo que se encaixem em uma determinada condição. Esta condição pode ser de valor ou de texto, e podem ser utilizados os sinais e coringas para consultar os valores maiores ou menores que, ou  ainda que possuam um determinado texto.

Objetivo

Contar as células de um intervalo que se encaixem em determinada condição.

Retorno

Valor numérico que identifica a quantidade de itens que atendem ao critério.

Sintaxe

=CONT.SE(intervalo; critérios)

Parâmetros

intervalo: Intervalo de células que serão contadas.

critérios: Critério pelo qual as células serão contadas

Como usar

A função cont.se permite que sejam contados valores de células numéricas ou de texto conforme os exemplos abaixo.

CONTAR CÉLULAS COM DETERMINADO NÚMERO

Exemplo Explicação
=CONT.SE(A1:A1000;50) Contar células com o valor igual a 50

No caso de valores numéricos exatos, basta selecionar o intervalo no primeiro parâmetro e no segundo parâmetro colocar o valor que deseja contar, sem necessidade de nenhum sinal lógico.

CONTAR CÉLULAS COM DETERMINADO TEXTO

Exemplo Explicação
=CONT.SE(A1:A1000;”Ana”) Contar células que possuem o texto Ana

Para contar células que tenham um determinado texto o texto a ser consultado deverá estar entre aspas duplas, pois caso não esteja este valor será interpretado pelo Excel como um intervalo nomeado, resultando em um erro.

O retorno da consulta acima será a contagem de todas as células que possuem apenas o nome Ana no interior da célula.

CONTAR CÉLULAS MAIOR QUE, MENOR QUE

Exemplo Explicação
=CONT.SE(A1:A1000;”>500″) Contar células com valor maior do que 500
=CONT.SE(A1:A1000;”<500″) Contar células com valor menor do que 500
=CONT.SE(A1:A1000;”>=500″) Contar células com valor maior ou igual a 500
=CONT.SE(A1:A1000;”<=500″) Contar células com valor menor ou igual a 500
=CONT.SE(A1:A1000;”<>500″) Contar células com valor diferente de 500

A função cont.se permite que sejam realizadas contagens também utilizando operadores matemáticos como o maior >, menor < e igual, inclusive combinados

Nos exemplos acima temos exemplos de uso da fórmula para consultar quando o valor da célula for, maior, menor, maior ou igual, menor ou igual e também se for diferente de um determinado valor.

CONTAR CÉLULAS QUE CONTENHAM TEXTO

Exemplo Explicação
=CONT.SE(A1:A1000;”*Nota*fi*”) Contar células que contenham um determinado texto
=CONT.SE(A1:A1000;”~*”) Contar células que contenham * no texto, ele elimina o coringa
=CONT.SE(A1:A1000;”?nt?nio”) Contar células que contenham * no texto

Para contar células que tenham um determinado texto pode ser usado o coringa *. No caso acima são contadas as células que contem os textos nota e fi, nesta sequência, mas precedidos e sucedidos por quaisquer outros caracteres.

Para contar as células que contém um caractere que é coringa para o Excel, use o ~ antes do coringa, neste caso ele elimina o uso do coringa pelo Excel, que o lê como um texto comum.

O coringa ? é utilizado para consultar textos aonde uma determinada posição no texto pode ser quaisquer caractere. Os coringas podem ser utilizado sem conjunto, tanto o * quanto o ? ou o ~ em uma mesma fórmula.

Faça o download dos exemplos com a função cont.se no botão abaixo.

Função Cont.se Excel

Abraço

Marcos Rieper

Veja mais sobre as funções e fórmulas do Excel em: https://www.guiadoexcel.com.br/funcoes-e-formulas-do-excel


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/
Cursos

Curso Excel Básico – 1 ano de acesso

R$99,00

COMPRAR
Cursos

Curso Excel Completo – Curso Excel Básico + Curso Excel Avançado – Acesso Vitalício

R$218,00 R$179,00

COMPRAR
Cursos

Curso Excel Master – Curso Excel Básico + Curso Excel Avançado + Curso VBA Excel + LP – Acesso Vitalício

R$357,00 R$249,00

COMPRAR
Cursos

Curso Excel PRO – Curso Excel Avançado + Curso VBA Excel + Lógica de programação – Acesso Vitalício

R$258,00 R$199,00

COMPRAR

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.