SE, Somase, Contse Excel Com Cláusula Contém

Controle de Projetos com Gantt e Tabela Dinâmica
Controle de Projetos com Gantt e Tabela Dinâmica
5 de fevereiro de 2012
Contar Valores Distintos Excel, Somar Valores Distintos Excel
Contar Valores Distintos Excel, Somar Valores Distintos Excel
19 de fevereiro de 2012

Objetivo: Demonstrar o uso da função Somase do Excel quando se quer somar dados em que uma das colunas contenham determinado texto.

Os operadores lógicos mais conhecidos do Excel são:

OPERADOR DE COMPARAÇÃO SIGNIFICADO (EXEMPLO)
= (sinal de igual) Igual a (A1=B1)
> (sinal de maior que) Maior que (A1>B1)
< (sinal de menor que) Menor que (A1<B1)
>= (sinal de maior ou igual a) Maior ou igual a (A1>=B1)
<= (sinal de menor ou igual a) Menor ou igual a (A1<=B1)
<> (sinal de diferente de) Diferente de (A1<>B1)

Estes operadores podem ser utilizados nas mais diversas funções que o Excel nos permite: E, FALSO, NÃO, OU SEERRO, VERDADEIRO.

Esta semana procurando uma forma de resolver um problema descobri um novo operador, o *.

A sua funcionalidade é a de CONTÉM, ou seja, se determinada célula ou cadeia de caracteres digitados na fórmula, possuem o valor determinado entre os operadores asterisco(*), independente do resto da célula, não realizando assim uma comparação exata da informação.

Exemplo: Contar os resultados de uma lista que possuam a palavra Brasil.

Levando em consideração que a lista esteja na coluna “I” temos na função =CONT.SE(Orders!I:I;”*Brasil*”), notando que a palavra Brasil ficou entre asteriscos.

Também pode ser feito o uso de operadores de concatenação para variar o conteúdo a ser comparado, como o exemplo do anexo e na função abaixo:

=CONT.SE(Orders!I:I;”*”&A2&”*”)

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/
Cursos

Curso Excel Completo – Curso Excel Básico + Curso Excel Avançado – Acesso Vitalício

R$218,00 R$179,00

COMPRAR
Cursos

Curso Excel Master – Curso Excel Básico + Curso Excel Avançado + Curso VBA Excel + LP – Acesso Vitalício

R$357,00 R$249,00

COMPRAR
Cursos

Curso Excel PRO – Curso Excel Avançado + Curso VBA Excel + Lógica de programação – Acesso Vitalício

R$258,00 R$199,00

COMPRAR
Cursos

Curso Excel Web – Curso VBA Excel + Lógica de programação + Curso Web Scraping VBA- Acesso Vitalício

R$388,90 R$309,00

COMPRAR

24 Comentários

  1. ++RiptoR++ disse:

    Este operador também me era desconhecido.
    Ele vai servir de atalho para alguns longos procedimentos que tomava para atingir certos objetivos nas planilhas. Muito obrigado, Marcos! Ajudou bastante!

  2. Eu vi esse operador uma vez num daqueles podcasts do Duelo entre o MrExcel e o ExcelIsFun, agora com essa explicação ficou ótimo.
    Obrigado,

  3. Padunic disse:

    Olá,

    tenho uma planilha e preciso contar a quantidade de letra C em uma determinada coluna.
    Posso usar este formato?

    =CONT.SES(F31:F785,”C”)

    Estou tentando mas esta dando erro.

    valeu pela ajuda.

    Padunic

  4. Gilberto disse:

    Muito bom a explicação e exemplo apresentado. Como sempre. Parabens!

  5. jefferson disse:

    Olá,
    eu gostaria de uma ajuda, pois estou tentando encontrar duas condições a partir de quatro ou cinco situações diferentes, sejam elas:
    arei+pedra+cimento e água = concreto

    eu quero chegar em uma fórmula que me proporcione a outra em informação em caso de falta de um dos igredientes. por exemplo
    areia+cimento+água = argamassa
    e se eu acrecentar mais um item aparecer outra condição:
    areia+pedra+cimanto+água+ferro=concreto-amarrado. sendo tudo isso na mesma célula. Como eu posso fazer isso. Já tentei a função se, ou, e, etc. não consegui com nenhuma.
    Desde já agradeço a atenção!!!

  6. Leonardo disse:

    Tudo bom?

    Seguinte, eu queria usar um texto no ‘teste lógico’, de formas que se eu escrever um determinado texto numa cédula ocorra uma condição. Ex =SE(h9=’bola’;D9=1;D9=0), porém não consigo fazer testes lógicos usando palavras, como faço para resolver isto?
    Grato

  7. Olá Marcos Rieper!

    Se você puder me ajudar ficarei grato.
    Tenho uma lista na coluna A e B com nomes de pessoas, preciso identificar quem está na coluna A e não em B e virse-versa, assim como quem está em A e B.

    Conseguir usando a função SE contudo os nomes devem está na mesma linha. Minha dificuldade é: Maria está em A1 e em B15 não consigo gerar uma lista que exiba Maria como duplicação, usando formatação condicional aplico cor e identifica aleatoriamente, mas quero algo que fique automático, basta colar nas colunas de comparação para gerar os nomes duplicados como citado anteriormente, contem em A e B, está em A e não em B, está em B e não em A.

    meu msn: fernandesbrasil@live.com

    Estou rodando na net e até agora nada! uma ajudinha aí amiguinho! Abraço e fique com Deus.. sucessos!

  8. Thianini disse:

    Olá. Tenho uma planilha com os países que participaram da copa do mundo de 1994 até 2010.

    Tenho que ver quantas vezes cada país participou. Tentei fazer dessa maneira olhando aqui mas não deu certo.

    Países Ano(1994) Paises Ano(1998) .. 2010

    =CONT.SES(C3:C26;E3:E34;G3:G34;I3:I34;K3:K34;”Brasil”)

    Conseguem me ajudar?

  9. Thianini disse:

    ninguem vai responder não ;/

  10. Leandro disse:

    Boa tarde Marcos,

    Como faço, por exemplo, se eu quiser saber quantos clientes diferentes compraram produtos de FabricaçãoBrasil no caso da sua planilha?

    Obrigado

  11. Daniela disse:

    Bom dia.
    Muito útil o operador. Consegui utilizar para funções Cont.ses e Somases.

    Porém, não consegui utilizá-lo na função SE. Neste caso, como fica a fórmula?

    Ex:
    =SE(B3=”*”&H6&”*”;1;0)

    =SE(B3=”*Erro*”;1;0)

    Em nehum dos casos consegui sucesso (o Excel considera o resultado como falso, sempre)

  12. Lito disse:

    como somar a quantidade de números diferentes de zero em uma linha? no exemplo abaixo, como chegar no resultado terno (3), ou quadra(4) ou quina(5).

    Grato

    0 7 0 35 56 Terno

  13. joao disse:

    Meu muito obrigado…….simplesmente sensacional..

  14. David disse:

    Bom dia!!

    Na formula abaixo:
    =(1*(P$6/100)*(R$4^2))/(1/(0,68*$A7*T$6*(1-0,4*$A7)))
    gostaria de condicionar que se as células R4 e P6 forem iguais a zero o calculo igual a =1/(0,68*$A7*B$6*(1-0,4*$A7)).

    Obrigado

    • Marcos Rieper disse:

      Boa noite David,

      Para isso faça uso da função SE e E em conjunto, assim: =SE(E(R4=0;P6=0;1/(0,68*$A7*B$6*(1-0,4*$A7)); (1*(P$6/100)*(R$4^2))/(1/(0,68*$A7*T$6*(1-0,4*$A7)))).

      Mas veja a sua função, coloquei no Excel e estava com alguma falha nela.

      Abraço

      Marcos Rieper

  15. Guillermo disse:

    Boa noite,

    Preciso de uma condicional usando o contém, onde tenho 2 planilhas de notas fiscais A planilha A me traz os dados das notas como NF-12 ou NF – 12 ou NF12, a planilha B tenho o dado da nota apenas o numero, ou seja, 12. Supondo que os dados estejam na celula A1 de cada planilha. Sendo assim preciso de uma formula que me traga algo do tipo:

    =SE(A!A1 contem B!A1;”NÃO PAGO”;”PAGO”)

    Como devo proceder?

  16. Leonardo disse:

    Marcos, muito obrigado! Não conhecia este operador e ele acabou de me poupar um tempo enorme! Abração

  17. Lelouch disse:

    Muito obrigado, estava precisando mto saber sobre como usar o CONTEM em uma formula.

  18. Dani disse:

    Marcos, muito obrigado! Não conhecia este operador e ele acabou de me poupar um tempo enorme! Abração

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.