SE, Somase, Contse Excel Com Cláusula Contém

Objetivo: Demonstrar o uso da função Somase do Excel quando se quer somar dados em que uma das colunas contenham determinado texto.

Os operadores lógicos mais conhecidos do Excel são:

OPERADOR DE COMPARAÇÃOSIGNIFICADO (EXEMPLO)
= (sinal de igual)Igual a (A1=B1)
> (sinal de maior que)Maior que (A1>B1)
< (sinal de menor que)Menor que (A1<B1)
>= (sinal de maior ou igual a)Maior ou igual a (A1>=B1)
<= (sinal de menor ou igual a)Menor ou igual a (A1<=B1)
<> (sinal de diferente de)Diferente de (A1<>B1)

Estes operadores podem ser utilizados nas mais diversas funções que o Excel nos permite: E, FALSO, NÃO, OU SEERRO, VERDADEIRO.

Esta semana procurando uma forma de resolver um problema descobri um novo operador, o *.

A sua funcionalidade é a de CONTÉM, ou seja, se determinada célula ou cadeia de caracteres digitados na fórmula, possuem o valor determinado entre os operadores asterisco(*), independente do resto da célula, não realizando assim uma comparação exata da informação.

Exemplo: Contar os resultados de uma lista que possuam a palavra Brasil.

Levando em consideração que a lista esteja na coluna “I” temos na função =CONT.SE(Orders!I:I;”*Brasil*”), notando que a palavra Brasil ficou entre asteriscos.

Também pode ser feito o uso de operadores de concatenação para variar o conteúdo a ser comparado, como o exemplo do anexo e na função abaixo:

=CONT.SE(Orders!I:I;”*”&A2&”*”)

Abraço

Marcos Rieper