PROCV Último Valor Excel

Veja como retornar o último valor de uma lista com PROCV no Excel de três formas diferentes.

Digamos que você tenha o seguinte cenário.

O cliente possui 3 máquinas e realiza medições diárias nas mesmas.

Ele deseja retornar sempre a última medição da máquina selecionada, para saber como está naquele momento.

Como retornar sempre a última medição da máquina selecionada?

Vejamos como realizar esta tarefa de 3 formas diferentes.

Retornar último valor com Procv no Excel em lista Classificada – Solução 1

No título desta sessão eu faço questão de frizar a palavra Classificada.

Pois esta solução irá funcionar perfeitamente, mas apenas se os seus dados estiverem classificados.

Nas sessões seguintes irá ver como fazer com listas não classificadas.

Para realizar o Procv conforme este exemplo, primeiro realize a classificação da sua fonte de dados pela coluna em que realizará a consulta, do menor para o maior.

Classificado pela coluna Máquina, que será a coluna de consulta

Com os dados classificados use a seguinte função:

=PROCV($H$6;$C$7:$D$24;2;1)

O PROCV possui 4 argumentos:

  1. valor_procurado: Valor que será pesquisado, tem que estar na primeira coluna da busca.
  2. matriz_tabela: lista ou tabela aonde serão pesquisados os dados, a primeira coluna tem que possuir o termo pesquisado.
  3. núm_índice_coluna: número da coluna retornada contando à partir da esquerda, no caso acima desejamos retornar a coluna 2, logo passamos 2.
  4. [procurar_intervalo]: este parâmetro define se você quer uma busca exata ou aproximada, no nosso exemplo passamos 1, pois queremos uma busca aproximada.

No último parâmetro estamos passando como citado acima uma busca aproximada e aqui está o truque.

Pois como é uma busca aproximada, o Excel tenta achar o mais próximo e vai até o último, mas atente novamente, só funciona para listas classificadas.

Retornar último valor com Procv no Excel com PROC – Solução 2

Para versões anteriores ao Excel 365 e listas não classificadas use esta opção para retornar o último valor do PROCV no Excel.

Para isso use a função abaixo:

=PROC(2;1/($C$7:$C$24=H6);$D$7:$D$24)

Veja que estamos usando a função PROC e não PROCV, veja os argumentos e depois explico a lógica:

  1. valor_procurado: este é o valor que será procurado na lista.
  2. vetor_proc: aqui estão os dados que serão pesquisados, é o vetor de busca, uma coluna, lista única.
  3. [vetor_result]: é o resultado dos dados, o que deseja retornar com relação a lista anterior.

Entendendo a função: Colocamos como primeiro argumento, o número 2, e no vetor de procura colocamos a fórmula que está comparando o valor da coluna de máquinas com a máquina selecionada.

isso resulta em um vetor com os seguintes dados: {FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;FALSO;VERDADEIRO;VERDADEIRO;VERDADEIRO;VERDADEIRO;VERDADEIRO;VERDADEIRO}

O que faz com que sejam retornados FALSO e VERDADEIRO, como acima.

Para o Excel FALSO = 0 e VERDADEIRO = 1, então na lista está sendo pesquisado o número 2, e como ele não acha, porque temos apenas 0 e 1, ele vai até o último 1 e retorna esta posição.

Com isso a posição correspondente no vetor de resultado é retornada.

Retornar último valor PROCV no Excel usando PROCX – Solução 3

Temos por fim a melhor solução, que de longe é a mais performática, no entanto, apenas funcionará em versões do Excel 365 e à partir do 2021.

O Procx é uma função que veio substituir a função PROCV, com muito mais performance e opções. Veja mais sobre PROCX.

No nosso exemplo usamos a seguinte função:

=PROCX($H$6;$C$7:$C$24;$D$7:$D$24;;0;-1)

A função PROCX possui 6 parâmetros:

  1. pesquisa_valor: valor que está sendo pesquisado.
  2. pesquisa_matriz: aonde será pesquisado.
  3. matriz_retorno: dados que serão retornados conforme a coluna de pesquisa.
  4. [se_não_encontrada]: se não encontrar ele retorna o valor ou texto que estiver neste parâmetro.
  5. [modo_correspondência]: 0-Correspondência exata, -1-Correspondência exata ou próximo item menor, 1-Correspondência exata ou próximo item maior, 2-Correspondência de caractere curinga. O padrão é o 0 e não mexemos aqui neste caso.
  6. [modo_pesquisa]: 1-Pesquisar do primeiro ao último, -1-Pesquisar último ao primeiro, 2-Pesquisa binária (ordem de classificação crescente), -2-Pesquisa binária (ordem de classificação decrescente. No caso usamos -1, pesquisar do último ao primeiro.

No exemplo acima, você não precisa ter uma lista ordenada ou usar uma função matricial para retornar os dados, basta você passar como o último parâmetro da função PROCX o valor -1, pois com este argumento no parâmetro a busca começará do último valor ao primeiro.

Reforçando, esta solução funciona apenas no Microsoft Excel 365 e 2021 em diante.

Download da Planilha Exemplo PROCV Último Valor Excel

Realize o download da planilha deste artigo no botão abaixo. Basta se inscrever na nossa newsletter gratuita para o download automático.

Baixe a planilha

Curso Excel Completo - Do Básico ao VBA

Quer aprender Excel do Básico, passando pela Avançado e chegando no VBA? Clique na imagem abaixo:


Marcos Rieper

Pai, marido, professor e consultor em Excel.

Obrigado por ler este artigo, este blog foi criado para difundir o conhecimento em Excel à todos.

Divulgamos novos artigos nas redes sociais, basta clicar nos ícones abaixo.

Excel não precisa ser complicado

Assine nossa newsletter e receba dicas práticas para dominar o excel