Como achar um valor aproximado Excel – Procv

Gráfico Excel com eixo Y com altura dinâmica VBA
Gráfico Excel com eixo Y com altura dinâmica VBA
7 de janeiro de 2015
Dicas para deixar a execução do VBA mais rápida e profissional
Dicas para deixar a execução do VBA mais rápida e profissional
18 de janeiro de 2015

Objetivo: Apresentar uma forma de localizar um valor aproximado Excel, independente se o valor é maior ou menor que o número.

Localizar valor aproximado ExcelPara identificar um valor aproximado no Excel não existe uma função específica, dado que o PROCV precisa de uma lista ordenada e também traz o valor mais baixo, mesmo que haja um valor mais alto que o valor aproximado, mas com uma diferença menor.

Na prática se estamos procurando o valor 1600 e na lista temos o valor 1500 e 1601, e queremos achar o valor mais próximo de 1600, o sistema trará 1500 se usar a função PROCV, que é o primeiro valor mais baixo e próximo.

Vamos agora á solução do problema:

1. Você tem uma lista com os valores aonde você quer identificar o valor mais próximo de um outro valor.

Localizar valor aproximado Excel 1

2. Digite em uma outra célula o valor que gostaria de localizar o valor aproximado:

Localizar valor aproximado Excel 2

3. Na coluna ao lado esquerdo do nome digite a seguinte fórmula: =ABS($B$2-G2) e arraste a função para todos os itens da lista.

Entendendo a função:

  • $B$2-G2 = Calcula a diferença entre o valor a ser identificado e o valor da coluna que está sendo procurada na lista.
  • ABS() = Esta função retorna o valor absoluto, ou seja, ignora o sinal de Menor(-) e sempre retorna um valor positivo.
  • =ABS($B$2-G2) = Então esta função retorna a diferença absoluta entre o valor procurado e a lista, por exemplo se a diferença for 50, retornará 50 e se for -50 também retornará 50.

  Localizar valor aproximado Excel 3

O resultado é o seguinte:Localizar valor aproximado Excel 5

4. Crie o local aonde serão exibidos os dados do retorno da busca, no caso colocamos os campos Valor, Nome e Data como segue na imagem.

Localizar valor aproximado Excel 4

5. No campo Valor digite a seguinte função para localizar o valor aproximado:

=PROCV(MÍNIMO(E:E);E:G;3;0)

Entendendo a função:

  • PROCV(): A função procv realiza a busca por um valor específico a partir de uma lista e retorna o valor correspondente de outra coluna. Caso não esteja familiarizado com esta função veja neste artigo como utilizá-la, inclusive com vídeo: http://guiadoexcel.com.br/procv-e-proch-excel
  • MÍNIMO: Esta função retorna o menor valor de uma lista, no nosso caso ele está apontando para a nossa lista criada:

Localizar valor aproximado Excel 6Veja que o intervalo da função Mínimo é E:E, ou seja, a nossa coluna criada para o cálculo da menor diferença. Assim, o valor que está sendo procurado é sempre o menor valor desta coluna.

O retorno da pesquisa é a coluna 3 a partir da coluna de busca, intervalo E:G, ou seja, o retorno será o conteúdo da coluna Valor, dado que 1=Cálculo, 2=Nome e 3=Valor.

6. No campo Nome, repita a função, mudando apenas a coluna de retorno de 3 para 2: =PROCV(MÍNIMO(E:E);E:G;2;0), o retorno será o nome.

Localizar valor aproximado Excel 7

7. Digite na coluna Data da pesquisa a seguinte fórmula: =PROCV(MÍNIMO(E:E);E:H;4;0), o retorno será a data.

O resultado final será:

Localizar valor aproximado Excel 8

Sendo assim, temos que o valor mais próximo de 1600, na nossa lista é o valor 1584, que tem a menor diferença 16, no caso.

Se tiver dúvidas, baixe o nosso exemplo clicando no botão Download ao final do artigo.

DIGITE O SEU EMAIL PARA FAZER O DOWNLOAD DOS ARQUIVOS:

Esse artigo foi útil? Você pode se interessar também por: Como usar o PROCV no Excel

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/

4 Comentários

  1. Myrian disse:

    Gostei muito do artigo Marcos.
    Está bem próximo de uma demanda que tenho.
    O detalhe é que preciso fazer a pesquisa de vários dados de uma vez… ou seja. tenho várias linhas com os valores a localizar… Alguma dica adicional?
    Postei minha dúvida no fórum dias atrás…
    Abs,

  2. elindoval disse:

    essa solução foi util ate certo ponto quand os numeros nao são fracionados algumas estão com diferença tipow (17,5 e outro com 18) ou ele escolhe o valor meno mais precisarei do outro valor, como posso resolver ?

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.