Procv aproximado com duas condições – Procv Excel

Objetivo: Demonstrar como utilizar o procv aproximado com duas condições, utilizando matrizes no Excel.

Procv aproximado com duas condições

A função Procv, é uma função de busca muito útil que relaciona dados de tabelas a partir de uma chave em comum.

Na situação proposta neste artigo temos a seguinte situação hipotética:

“A empresa A possui responsáveis pelas vendas de suas cidades que são trocados periodicamente. Fazer uma lista para retornar o funcionário responsável pelas vendas de cada cidade partindo de uma lista em que temos a cidade, a data a partir da qual o funcionário se tornou responsável e o nome do mesmo.”

Sendo assim, temos a nossa lista base com a cidade, a data a partir da qual o funcionário se tornou responsável e o nome do mesmo:

Procv aproximado com duas condições 1

Criamos então uma nova lista somente com o nome das cidades que queremos identificar o responsável a partir de uma data digitada:

Procv aproximado com duas condições 2 Excel

Na coluna responsável iremos digitar a seguinte fórmula:

=PROCV($F$1;SE($A$2:$A$67=E4;$B$2:$C$67);2;1), e pressionamos CTRL+ENTER ao invés de ENTER.

Entendendo a fórmula:

=PROCV($F$1 = $F$1 é o primeiro parâmetro da função PROCV, é o campo de data que criamos e que queremos localizar;

SE($A$2:$A$67=E4;$B$2:$C$67) = Esta parte da fórmula é a que filtra que somente queremos que sejam retornadas as datas das cidades que forem iguais á E4, sendo E4 a cidade de Botuverá, serão retornados somente os dados de B2:C67 que forem desta mesma cidade, no caso serão retornadas:

Procv aproximado com duas condições 3 Excel

;2;1) = é a parte da função PROCV que define o que será retornado, no caso o 2 identifica que será retornada a segunda coluna da seleção B2:C67, ou seja, os dados da coluna C equivalentes, e o valor 1 na função identifica que deve ser realizada uma busca aproximada.

Esta busca aproximada retornará sempre o valor maior ou igual ao que está sendo retornado, exemplo:

A partir da lista:

Procv aproximado com duas condições 4 Excel

Buscando os seguintes valores:

  • 01/01/1900, retornará Anselmo;
  • 15/12/2014, retornará Anselmo;
  • 01/01/2015, retornará João;
  • 31/01/2015, retornará João;
  • 01/02/2015, retornará Bruno;
  • 31/12/2016, retornará Bruno

Atenção: Esta fórmula que explicamos faz uso do recurso MATRICIAL no Excel, veja mais em: Filtro avançado e fórmulas matriciais, por isso é necessário que ao digitar a função seja digitado CTRL+ENTER ao invés de ENTER somente.

Clicando no botão abaixo você terá o exemplo da planilha que utilizamos neste artigo:

DIGITE O SEU EMAIL PARA FAZER O DOWNLOAD DOS ARQUIVOS: Baixe a planilha

Abraço

Marcos Rieper