Procv aproximado com duas condições – Procv Excel

Alinhar e ajustar imagens no Excel VBA
Alinhar e ajustar imagens no Excel VBA
6 de fevereiro de 2015
Congresso nacional de Excel Online - Inscreva-se
Congresso nacional de Excel Online – Inscreva-se
16 de fevereiro de 2015

Objetivo: Demonstrar como utilizar o procv aproximado com duas condições, utilizando matrizes no Excel.

Procv aproximado com duas condições

A função Procv, é uma função de busca muito útil que relaciona dados de tabelas a partir de uma chave em comum.

Na situação proposta neste artigo temos a seguinte situação hipotética:

“A empresa A possui responsáveis pelas vendas de suas cidades que são trocados periodicamente. Fazer uma lista para retornar o funcionário responsável pelas vendas de cada cidade partindo de uma lista em que temos a cidade, a data a partir da qual o funcionário se tornou responsável e o nome do mesmo.”

Sendo assim, temos a nossa lista base com a cidade, a data a partir da qual o funcionário se tornou responsável e o nome do mesmo:

Procv aproximado com duas condições 1

Criamos então uma nova lista somente com o nome das cidades que queremos identificar o responsável a partir de uma data digitada:

Procv aproximado com duas condições 2 Excel

Na coluna responsável iremos digitar a seguinte fórmula:

=PROCV($F$1;SE($A$2:$A$67=E4;$B$2:$C$67);2;1), e pressionamos CTRL+ENTER ao invés de ENTER.

Entendendo a fórmula:

=PROCV($F$1 = $F$1 é o primeiro parâmetro da função PROCV, é o campo de data que criamos e que queremos localizar;

SE($A$2:$A$67=E4;$B$2:$C$67) = Esta parte da fórmula é a que filtra que somente queremos que sejam retornadas as datas das cidades que forem iguais á E4, sendo E4 a cidade de Botuverá, serão retornados somente os dados de B2:C67 que forem desta mesma cidade, no caso serão retornadas:

Procv aproximado com duas condições 3 Excel

;2;1) = é a parte da função PROCV que define o que será retornado, no caso o 2 identifica que será retornada a segunda coluna da seleção B2:C67, ou seja, os dados da coluna C equivalentes, e o valor 1 na função identifica que deve ser realizada uma busca aproximada.

Esta busca aproximada retornará sempre o valor maior ou igual ao que está sendo retornado, exemplo:

A partir da lista:

Procv aproximado com duas condições 4 Excel

Buscando os seguintes valores:

  • 01/01/1900, retornará Anselmo;
  • 15/12/2014, retornará Anselmo;
  • 01/01/2015, retornará João;
  • 31/01/2015, retornará João;
  • 01/02/2015, retornará Bruno;
  • 31/12/2016, retornará Bruno

Atenção: Esta fórmula que explicamos faz uso do recurso MATRICIAL no Excel, veja mais em: Filtro avançado e fórmulas matriciais, por isso é necessário que ao digitar a função seja digitado CTRL+ENTER ao invés de ENTER somente.

Clicando no botão abaixo você terá o exemplo da planilha que utilizamos neste artigo:

DIGITE O SEU EMAIL PARA FAZER O DOWNLOAD DOS ARQUIVOS:

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/

7 Comentários

  1. Edly cruz disse:

    Showwww, preciso de ajuda em minha planilha,”onde quero saber o menor valor dos itens que quero comprar, sendo que possuo 5 fornecedores, mas eu gostaria que o excel destacasse a celula, tipo , a cor verde eu compro, a vermelha não compro.” só as duas cores!!!!!! como posso fazer.

    grato

  2. Diego Silva disse:

    Parabéns pelo blog.
    Ele está recheado de dicas úteis.
    Algumas delas me ajudaram muito no complemento do meus estudos.

  3. Nádila disse:

    Lembrando que é CTRL + SHIFT + ENTER para usar o recurso matricial.

  4. Gostaria de uma ajuda.
    Estou desenvolvendo uma planilha de controle e cadastro de livros de nossa biblioteca e estou precisando de uma fórmula para me mostrar o maior valor (número de um determinado livro que já está cadastrado).
    Preciso utilizar a variável (letra inicial do livro) pois estão organizados por ordem alfabética, mas suas numerações são crescentes por letra, ou seja: Letra A: Livro 1, 2, 3 , 4…… Letra J: Livro 1, 2, 3, 4…. Letra R: Livro 1, 2, 3, 4…. Não sei se fui claro.
    Na mesma planilha tenho uma coluna com as letras A, B, C, D….. outra coluna com o número do livro cadastrado, por exemplo a letra A tenho do numero 1 ao 244 livros, na letra B tenho do numero 1 ao 150 livros.
    Preciso que quando eu digitar a letra inicial do livro que estou cadastrando ele me traga o maior número cadastrado nesta planilha referente a letra inicial do livro para que possa utilizar esse numero mais um e cadastrar o novo livro.
    Parece complicado né!!!
    Abraços

    • Marcos Rieper disse:

      Boa tarde Sílvio,

      É necessário utilizar uma fórmula matricial ou a função Máximose se o seu Excel tiver.

      Vou fazer um artigo á respeito, obrigado pelo seu contato.

      Abraço
      Marcos Rieper

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.