Planilha de Distâncias entre Cidades no Excel

Planilha de Distâncias entre Cidades no Excel

Nesta planilha você terá as distâncias entre várias capitais e grandes cidades do Brasil e como buscar estes dados de uma forma simples na planilha definindo a cidade de origem e destino e retornando a distância entre elas.

Como retornas as distâncias entre duas cidades no Excel

Com base nas informações contidas na planilha do DNIT com a distância entre as principais cidades, vamos fazer passo-a-passo uma busca utilizando fórmulas para localizar a informação de forma rápida.

Siga o tutorial abaixo que demonstra como buscar a distância entre duas cidades nesta planilha.

Lembrando que para aumentar a sua base, basta digitar novas cidades nas colunas e linhas e alimentar as distâncias para que a planilha fique automaticamente atualizada.

A base de dados matricial das cidades está em uma planilha da pasta de trabalho.

1. A base de dados está disposta em linhas e colunas, sendo que as colunas chamamos de origem e as linhas de destino apenas afim de nomenclatura e entendimento ao longo do artigo.

A planilha base de distância entre cidades está então disposta da seguinte forma:

2. Selecione as cidades na primeira coluna e nomeie o intervalo como “Origem“, digitando esta informação na caixa de nome, ou na guia Fórmulas Definir nome.

3. Selecione as cidades destino na primeira coluna e na caixa de nome, nomeie o intervalo como “Distancia“.

4. Em uma nova planilha digite nas células as informações abaixo:

5. Selecione a célula ao lado do campo descrito como origem, clique na guia Dados e selecione a opção Validação de Dados.

Nesta opção selecione em Permitir a opção Lista, e em fonte digite =Origem, que é exatamente as cidades da primeira coluna.

6. Selecione a célula ao lado do campo descrito como destino, clique na guia Dados e selecione a opção Validação de Dados.

Nesta opção selecione em Permitir a opção Lista, e em fonte digite =Destino, que é exatamente as cidades da primeira linha.

7. Na célula ao lado do campo distância digite a fórmula conforme abaixo.

=ÍNDICE(QUADIST!A2:AL113;CORRESP(‘Distância entre cidades’!F8;QUADIST!A2:A113; 0);CORRESP(‘Distância entre cidades’!F9;QUADIST!A2:AL2; 0))&” KM”

A explicação para utilização das fórmulas ÍNDICE e CORRESP você pode ler no artigo https://guiadoexcel.com.br/indice-corresp.

O resultado final é conforme abaixo, ao selecionar a origem e o destino a planilha busca automaticamente a distância.

Download da planilha

Para realizar o download desta planilha de distâncias entre cidades Excel, basta clicar no botão abaixo e fazer parte do grupo do Guia do Excel.

Nele você receberá e-mails semanais com novos artigos, dicas e ofertas de treinamentos e planilhas que irão te ajudar na sua carreira e trabalho.

Baixe a planilha

Planilha de manutenção de frota de veículos

Caso você tenha uma frota de veículos, sabe como é importante controlar os seus gastos e que há muita coisa envolvida e que não pode ficar pra trás.

Veja neste artigo uma planilha gratuita de manutenção de frota de veículos https://www.guiadoexcel.com.br/planilha-excel-de-controle-de-despesas-e-manutencao-de-veiculos/

Manutenção de veículos Excel 4

Marcos Rieper