Painel de Acompanhamento de Projetos – Excel

Objetivo: Demonstrar como criar um indicador de status de projetos.

Este artigo tem como finalidade demonstrar como criar uma estrutura simples para o monitoramento do status de vários projetos de forma rápida.

O painel criado foi baseado em uma estrutura de acompanhamento utilizada na metologia de desenvolvimento de software FDD (Feature-Driven Development), para saber mais a respeito da metologia veja este site http://engenharia-de-software.nuvvo.com/lesson/11129-projeto-de-software-com-fdd.

Vamos a construção do painel:

1. Crie uma tabela base de dados com os campos:

  • Projeto: Nome do projeto;
  • Tarefas: Nome da tarefa;
  • Recurso: Recurso da execução da tarefa, funcionário/ferramenta/empresa/terceiro;
  • Início: Data inicial da tarefa;
  • Final: Data final da tarefa;
  • Percentual conclusão: Percentual da conclusão da tarefa;
  • Horas: Quantidade de horas da atividade;
  • Auxiliar: Cálculo de Horas * Percentual conclusão, para servir ao acompanhamento do projeto.

2. Desenha a tabela conforme a estrutura do desenho abaixo, não sendo necessárias as cores e as fórmulas que veremos em seguida.

3. Nesta estrutura temos os campos conforme a descrição da figura:

4. Par ao primeiro campo Nome do projeto você deve somente digitar o nome de um dos projetos

5. Para o campo Percentual concluído do projeto temos a fórmula:

  • =SOMASE(Base!$A:$A;C6;Base!$H:$H)/SOMASE(Base!$A:$A;C6;Base!$G:$G)
  • Esta fórmula faz a soma condicional da coluna Auxiliar para o projeto definido na célula C6 e depois divide pela soma condicional da coluna Horas também para o projeto definido na célula C6.

6. No campo Data final da última tarefa (encerramento do projeto) foi utilizada a fórmula:

  • {=MAIOR(SE(Base!$A:$A=M6;Base!$E:$E);1)}, lembrando que para incluir os colchetes você deve digitar CTRL+ENTER ao final da fórmula.
  • A função MAIOR traz o enésimo campo de uma lista de dados, =MAIOR(A:A, 1) traria o maior número, dado que foi passado o número 1 como parâmetro
  • A parte da função SE(Base!$A:$A=M6;Base!$E:$E) cria uma matricial aonde são trazidos os dados quando na coluna Base!$A:$A estiver digitado o nome do projeto e cria uma matriz de dados da coluna E.

7. Agora vamos criar a formatação condicional. Selecione o campo Percentual concluído do projeto no nosso indicador e clique em Página Inicial->Formatação Condicional->Barra de Dados.

8. Selecione a regra criada e altere o Tipo Mínimo e Máximo conforme a figura abaixo.

9. Clique sobre o nome do projeto e crie as regras condicionais clicando sobre Usar uma fórmula para determinar quais células devem ser formatadas conforme as condições abaixo:

  • Vermelho:=SE(E(C10<1;C11<HOJE());1;0)=1
  • Sem cores: =E10=0
  • Amarelo:=E(E10>0;E10<1)
  • Verde:=E10=1

As cores determinam o status do projeto sendo:

Vermelho: projeto em atraso

Sem cores: projeto não iniciado

Amarelo: projeto em desenvolvimento

Verde: projeto concluído

Baixe a planilha

Abraço

Marcos Rieper

Abraço

Marcos Rieper