Soma Absoluta Utilizando Fórmula Matricial

Função Aleatório Fixo
Função Aleatório Fixo
1 de junho de 2011
Me siga no Twitter
Me siga no Twitter
4 de junho de 2011

Objetivo: Demonstrar o uso de uma fórmula matricial para realizar a soma absoluta de uma lista de valores.


//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.

 

Para apuração de diferenças em uma conciliação de dados muitas vezes a diferença é apurada pela soma normal, ou seja, valores positivos e negativos são somados diretamente, gerando desta forma uma informação equívoca para este trabalho, na minha opinião.

Digo isso porque esta diferença pode distorcer a informação do verdadeiro problema das diferenças, dado que em um mês este valor pode por acaso dar uma diferença baixa, mas em outro mês um dos dois lados, o positivo ou negativo podem disparar, deixando evidente o erro que estava mascarado e poderia ter sido analisado antes.

Para realizar uma soma absoluta das diferenças, sem considerar se o valor é positivo ou negativo e gerando apenas valores positivos.

Eu imaginei duas formas para fazer isso no Excel, uma na força bruta e outra utilizando fórmulas matriciais.

Na primeira forma você utiliza a função ABS, cuja função é tornar um valor absoluto, ou seja, desconsiderar o sinal do valor.

Em uma coluna ao lado dos valores você digita a função =ABS(A1) e arrasta para a sua lista de valores e utiliza a soma direta dos valores utilizando a função SOMA.

Outra solução que eu julgo mais inteligente, elegante e prática é a utilização de uma fórmula matricial utilizando as duas funções da seguinte forma:

=SOMA(ABS(A1:A59)), porém no momento de dar o ENTER pressione as teclas CTRL+SHIFT+ENTER, isso fará com que a fórmula se torne matricial, ou seja, a fórmula de dentro será aplicada para todas as células antes de aplicar a soma. A fórmula ficará assim: {=SOMA(ABS(A1:A59))}, e o resultado será semelhante ao obtido utilizando a lista de valores auxiliar.

Você também pode ver um pouco mais sobre fórmulas matriciais no post FILTRO AVANÇADO E FÓRMULAS MATRICIAIS.

GUT PPT

Abraço

Marcos Rieper

//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.

 


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/

2 Comentários

  1. Tenho grande interesse sobre os recursos de excel e navegando neste SITE pude observar muitas novidades, muito bom!
    gostaria se possível de mais detalhes sobre os gráficos com animação (as formulas usadas para os cálculos).
    Estão de parabéns pelas ferramentas publicadas.
    1 abraço!

  2. Boa sacada, muito interessante e produtivo.
    Tenho um problema, tentei utilizar esse mesmo conceito na função somase() e ele não permite.
    somase(c1:c10;a1;abs(d1:d10) quando vou dar ctrl shfit enter ele não permite.
    Outro problema que eu tenho é que na função somase() ele considera com iguais para somar células com texto 01 e 000000001, como são textos o excel não deveria considerar como iguais.
    Qualquer ajuda é bem vinda.
    Obrigado.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.