Soma Absoluta Utilizando Fórmula Matricial

Objetivo: Demonstrar o uso de uma fórmula matricial para realizar a soma absoluta de uma lista de valores.


//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.

 

Para apuração de diferenças em uma conciliação de dados muitas vezes a diferença é apurada pela soma normal, ou seja, valores positivos e negativos são somados diretamente, gerando desta forma uma informação equívoca para este trabalho, na minha opinião.

Digo isso porque esta diferença pode distorcer a informação do verdadeiro problema das diferenças, dado que em um mês este valor pode por acaso dar uma diferença baixa, mas em outro mês um dos dois lados, o positivo ou negativo podem disparar, deixando evidente o erro que estava mascarado e poderia ter sido analisado antes.

Para realizar uma soma absoluta das diferenças, sem considerar se o valor é positivo ou negativo e gerando apenas valores positivos.

Eu imaginei duas formas para fazer isso no Excel, uma na força bruta e outra utilizando fórmulas matriciais.

Na primeira forma você utiliza a função ABS, cuja função é tornar um valor absoluto, ou seja, desconsiderar o sinal do valor.

Em uma coluna ao lado dos valores você digita a função =ABS(A1) e arrasta para a sua lista de valores e utiliza a soma direta dos valores utilizando a função SOMA.

Outra solução que eu julgo mais inteligente, elegante e prática é a utilização de uma fórmula matricial utilizando as duas funções da seguinte forma:

=SOMA(ABS(A1:A59)), porém no momento de dar o ENTER pressione as teclas CTRL+SHIFT+ENTER, isso fará com que a fórmula se torne matricial, ou seja, a fórmula de dentro será aplicada para todas as células antes de aplicar a soma. A fórmula ficará assim: {=SOMA(ABS(A1:A59))}, e o resultado será semelhante ao obtido utilizando a lista de valores auxiliar.

Você também pode ver um pouco mais sobre fórmulas matriciais no post FILTRO AVANÇADO E FÓRMULAS MATRICIAIS.

GUT PPT

Abraço

Marcos Rieper

//

Lomadee, uma nova espécie na web. A maior plataforma de afiliados da América Latina.