Lista Dinâmica Excel com Imagens – Procv com Imagens

Objetivo: Demonstrar a utilização de fórmulas Excel para localizar uma imagem a  partir de uma lista.

Colaboração: Carlos Eduardo Pessoa Soares Júnior, muito obrigado.

Uma planilha interessante enviado pelo nosso amigo Carlos Eduardo citado no início do artigo, demonstra como podemos fazer para a partir de uma lista retornar uma imagem.

Para isso você deve:

1. Criar uma lista com os nomes e as imagens, cada qual em uma coluna, conforme a planilha do exemplo deste artigo;

2. Clique na guia Fórmulas->Gerenciador de Nomes->Novo e defina um nome para o campo calculado, no nosso caso será Figura;

3. Ainda na mesma tela em Refere-se a digite a fórmula =ÍNDICE(Plan1!$C$2:$C$11;CORRESP(Plan1!$F$2;Plan1!$A$2:$A$11;0)) em que temos:

  • Plan1!$C$2:$C$11 o intervalo aonde estão as figuras;
  • Plan1!$F$2 o local aonde será escolhido o que se quer procurar;
  • Plan1!$A$2:$A$11 aonde será procurado o nome.

Mais sobre índice corresp em: http://guiadoexcel.com.br/indice-corresp.

4. Clique na célula F2 e clique na guia Dados->Validação de Dados, selecione no campo Permitir a opção Lista e no campo Fonte selecione o intervalo em que há os nomes a serem procurados, no caso do exemplo =$A$2:$A$11;

5. Em G2 digite a fórmula ÍNDICE(B2:B11;CORRESP(F2;A2:A11;0)) aonde temos em B2:B11 o intervalo de retorno, em F2 o que se quer localizar e em A2:A11 o intervalo de busca, semelhante ao da imagem anterior;

[saiba_mais]6. Na célula H2 insira uma imagem, pode ser qualquer uma, e em seguida vem a mágica, digite clicando sobre a figura selecionada e no campo Fórmula da planilha =Figuras, aonde Figuras é o nome que havíamos dado ao nome definido.

Então é isso, muito obrigado pela leitura e em especial ao Carlos pela colaboração.

Baixe a planilha

Abraço

Marcos Rieper