Gráfico com tamanho dinâmico Dashboard Excel

Planilha de fluxo de caixa simples Excel
8 de fevereiro de 2016
Planilha de fornecedores Excel – Cadastro de fornecedores
20 de fevereiro de 2016

Gráfico com tamanho dinâmico Dashboard Excel

Neste artigo é demonstrado como criar um gráfico de dashboard Excel com tamanho dinâmico.

Você aprenderá a criar uma planilha aonde o usuário irá selecionar os dados que gostaria de apresentar no gráfico, e ele automaticamente irá criar uma lista somente com os dados selecionados e gerar um gráfico somente com estes dados.

Preparando a planilha

Prepare uma planilha da seguinte forma:

Gráfico com itens selecionados Excel Dashboard

  • Vendedor: Número sequencial único, deve ser 1,2,3,4,… Este número é utilizado na fórmula.
  • Nome vendedor: Nome do vendedor ou dado que será utilizado no nome da coluna do gráfico.
  • Valor: Valor que será utilizado no gráfico.
  • Selecionar: Esta coluna deve ser marcada com “x” para os itens que quiser que constem no gráfico.

Na coluna F escreva Nome Vendedor e na coluna G digite Valor, esta será a tabela utilizada para a montagem do gráfico.

Gráfico com itens selecionados Excel Dashboard 2

Na célula F1, digite a fórmula: =SEERRO(PROCV(MENOR(SE($D$2:$D$12=”x”;$A$2:$A$12);LIN()-1);$A:$C;2;0);””) e pressione CTRL+ENTER, criando assim uma função matricial que irá retornar somente os dados da lista que estiverem marcado com X e que sejam da coluna Nome vendedor.

Para a função ficou matricial verifique se o Excel inseriu chaves antes e no final da fórmula {}.

Gráfico com itens selecionados Excel Dashboard 3

Na célula G1 digite a fórmula: =SEERRO(PROCV(MENOR(SE($D$2:$D$12=”x”;$A$2:$A$12);LIN()-1);$A:$C;3;0);”x”) e pressione CTRL+ENTER para que a função fique matricial. Para saber se ficou correta, verifique se ela ficou com colchetes antes e no final da função.

Após isso arraste as fórmulas até a linha 100 ou pelo menos na mesma altura da sua lista, se ela não tiver novos dados.

O resultado será o abaixo, aonde temos uma lista de dados criada somente com os itens marcados com x na lista da coluna A. Altere os itens marcados com x deletando eles e marcando outros para ver a lista mudando.

Gráfico com itens selecionados Excel Dashboard 4

Criando o gráfico

Clique na guia Fórmulas e no botão Gerenciador de Nomes, clique no botão Novo, nomeie como Valores e digite a seguinte fórmula: =DESLOC(Planilha1!$G$2;0;0;CONT.NÚM(Planilha1!$G:$G);1).

Gráfico com itens selecionados Excel Dashboard 5

Clique no otão Novo novamente e crie um novo intervalo chamado Vendedores com a seguinte fórmula: =DESLOC(Planilha1!$F$2;0;0;CONT.NÚM(Planilha1!$G:$G);1)

Gráfico com itens selecionados Excel Dashboard 6

Selecione as células preenchidas nas colunas F e G, inclusive o cabeçalho e pressione ALT+F1, o Excel irá criar o gráfico que iremos trabalhar.

Selecione o gráfico criado, selecione a guia Ferramentas de Gráfico e no agrupamento Design.

Clique em Selecionar Dados, selecione a lista de valores na guia Entradas e altere conforme a imagem abaixo:

Gráfico com itens selecionados Excel Dashboard 9

Gráfico com itens selecionados Excel Dashboard 7

Da mesma forma clique no botão Editar na guia de valores do eixo horizontal e altere conforme a imagem abaixo:

Gráfico com itens selecionados Excel Dashboard 8

Agora o seu gráfico de dashboard Excel com itens selecionados está pronto:

Gráfico com tamanho dinâmico Excel

Clique no botão abaixo para fazer o download do exemplo completo.

Abraço

Marcos Rieper


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/
Cursos

Curso Excel Completo – Curso Excel Básico + Curso Excel Avançado – Acesso Vitalício

R$218,00 R$179,00

COMPRAR
Cursos

Curso Excel Master – Curso Excel Básico + Curso Excel Avançado + Curso VBA Excel + LP – Acesso Vitalício

R$357,00 R$249,00

COMPRAR
Cursos

Curso Excel PRO – Curso Excel Avançado + Curso VBA Excel + Lógica de programação – Acesso Vitalício

R$258,00 R$199,00

COMPRAR
Cursos

Curso Excel Web – Curso VBA Excel + Lógica de programação + Curso Web Scraping VBA- Acesso Vitalício

R$388,90 R$309,00

COMPRAR

2 Comentários

  1. andre disse:

    Como adicionar a referencia “Grafico.xlsm!Valores” ou “Grafico.xlsm!Vendedor” ?? o Excel nao da esta opção.

  2. fernando disse:

    Muito bom

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.