Como fazer uma lista valores únicos no Excel com fórmula

Classificar automaticamente com matriciais números repetidos capa
Classificar dados repetidos no Excel com fórmula
6 de outubro de 2018
Curso Web Scraping VBA Excel Capa
Curso Web Scraping VBA Excel
27 de outubro de 2018

Como fazer uma lista valores únicos no Excel com fórmula

O Excel possui a funcionalidade remover duplicatas. Como fazer uma lista de valores únicos no Excel com fórmula?

 

Como fazer uma lista valores únicos no Excel

 

No exemplo acima nós temos uma lista de produtos com as suas respectivas categorias.

Você poderia extrair uma lista de dados única com uma tabela dinâmica ou com o remover duplicatas, o problema é que sempre é necessário realizar a uma atualização no caso da tabela dinâmica ou fazer todo o processo de copiar a coluna e remover duplicatas.

Veja agora como fazer este processo com fórmulas no Excel.

Conheça outros artigos de Excel Avançado nesta categoria do blog: https://www.guiadoexcel.com.br/excel-avancado/

 

Fórmula para fazer uma lista de valores únicos no Excel

A fórmula utilizada para termos uma lista sem duplicatas é uma fórmula matricial.

 

Como fazer uma lista valores únicos no Excel

 

As fórmulas matriciais trabalham de uma forma diferente da maioria das fórmulas padrões no Excel.

Para solucionar este problema nós utilizamos na fórmula as funções SEERRO, ÍNDICE, CORRESP e CONT.SE, vamos entender agora como ela funciona e como implementá-la.

 

Entendendo a Fórmula

Vamos entender agora a fórmula para a lista de valores únicos do Excel por etapas.

Fórmula: {=SEERRO(ÍNDICE($A$2:$A$501; CORRESP(0; CONT.SE($F$1:F9;$A$2:$A$501);0));”X”)}

  1. (ÍNDICE($A$2:$A$501: Aqui é criada uma lista de valores com todos os valores da sua lista que serão removidos os duplicados.
  2. CORRESP(0;CONT.SE($F$1:F9;$A$2:$A$501);0): Aqui nós temos uma lista de dados de $F$1:F9, perceba que o F9 está com o tamanho dinâmico, ou seja, a lista irá aumentar conforme é arrastada para as células abaixo. Além disso temos o CONT.SE que realiza a soma se houverem valores de F1:F9 na lista de A2:A501. O CORRESP realiza a busca do primeiro valor que não for encontrado na lista acima.
  3. Ao final da fórmula é necessário pressionar as teclas CTRL+SHIFT+ENTER para que seja entendida como uma fórmula matricial.

 

Reduzimos o intervalo para demonstrarmos como funciona a fórmula matricial, veja abaixo:

=SEERRO(ÍNDICE({“Peça”;”Vídeo”;”Comunicação”;”Vídeo”;”Notebook”;”Peça”;”Monitor”;”Monitor”;”Peça”};CORRESP(0;CONT.SE({“Categorias”;”Peça”};{“Peça”;”Vídeo”;”Comunicação”;”Vídeo”;”Notebook”;”Peça”;”Monitor”;”Monitor”;”Peça”});0));”X”)

Abrindo a fórmula com F9 em cada parte da fórmula nós temos a primeira parte aonde temos o intervalo de busca:

{“Peça”;”Vídeo”;”Comunicação”;”Vídeo”;”Notebook”;”Peça”;”Monitor”;”Monitor”;”Peça”}

Na lista nós temos itens que já estão listados como únicos nas células anteriores:

{“Peça”;”Vídeo”;”Comunicação”}

Sendo assim, o sistema identifica que a próxima que deverá ser buscada é a palavra Vídeo, dado que já foi retornado na célula anterior as palavras Peça, Vídeo e Comunicação a próxima palavra retornada será a palavra Notebook.

 

Conclusão

Para várias finalidades esta fórmula para uma lista dinâmica de dados como por exemplo listas de validações, relatórios e dashboards.

Veja outra fórmula matricial no Excel: Classificar dados repetidos no Excel com fórmula

 

 

Leia também sobre:
Como usar Fórmula / Funções Excel no VBA

Função Formulário no Excel

 


Clique aqui e leia mais sobre Excel VBA. https://www.guiadoexcel.com.br/vba/ O Guia do Excel foi criado por Marcos Rieper e oferece artigos, dicas, tutoriais e modelos de planilhas prontas. Aqui você encontra tudo sobre Excel, seja de nível básico, intermediário,  avançado e VBA. O Guia do Excel oferece diversos materiais completamente gratuitos para download. Navegue em nosso site e confira! Conheça também a nossa Loja do Excel https://loja.guiadoexcel.com.br/
Cursos

Curso Excel Completo – Curso Excel Básico + Curso Excel Avançado – Acesso Vitalício

R$218,00 R$179,00

COMPRAR
Cursos

Curso Excel Master – Curso Excel Básico + Curso Excel Avançado + Curso VBA Excel + LP – Acesso Vitalício

R$357,00 R$249,00

COMPRAR
Cursos

Curso Excel PRO – Curso Excel Avançado + Curso VBA Excel + Lógica de programação – Acesso Vitalício

R$258,00 R$199,00

COMPRAR
Cursos

Curso Excel Web – Curso VBA Excel + Lógica de programação + Curso Web Scraping VBA- Acesso Vitalício

R$388,90 R$309,00

COMPRAR

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Inscreva-se no nosso canal do Youtube!


Junte-se ao nosso canal do Youtube. Começamos em abril de 2016, mas já temos mais de 06:00 h de treinamentos gratuitos e este número irá aumentar. Vídeos novos todos os sábados.