Formatação Condicional em Gráficos no Excel

Neste artigo você aprenderá como realizar formatação condicional em gráficos no Excel.

Gráfico Destacar Maiores e Menores Valores

Neste gráfico temos o destaque das colunas com maiores ou menores valores conforme temos abaixo:

Formatação Condicional em Gráficos Excel 1

Para exibir este gráfico destacado temos então a seguinte estrutura:

Formatação Condicional em Gráficos Excel 2
  • Nome: Nome do campo que será exibido no gráfico.
  • Valor: Valor do gráfico
  • Valor: Valor a ser destacado no gráfico. Nela é usada a fórmula: =SE(E8<=$C$5;C8;NÃO.DISP()) aonde é verificado se é menor ou igual ao item no ranking.
  • Ranking: No ranking nós temos a posição de cada valor na tabela. Foi usada a fórmula: =ORDEM(C8;$C$8:$C$19;$G$5-1)
  • Rótulo: A função de rótulo cria um rótulo que será usado no gráfico =SE(E8<=$C$5;TEXTO(E8;”# º”)&” – “&TEXTO(C8;”#,00”);NÃO.DISP())
  • Eixo X: Nesta coluna usamos uma fórmula para retornar no eixo X rótulos dinâmicos. A fórmula utilizada foi: =SE(É.NÃO.DISP(F8);B8;TEXTO(E8;”# º”)&”-“&ESQUERDA(B8;3))

Como resultado da estrutura que criamos conforme no vídeo ao topo do artigo, você tem o efeito abaixo, destacando então no gráfico os valores conforme a posição de menor ou maior e colocando os valores ao topo.

Formatação Condicional em Gráficos Excel 3

Destacar Valor Acima da Média

A tabela que utilizamos no gráfico foi a seguinte aonde temos então os campos:

Formatação Condicional em Gráficos Excel 4
  • Nome: Nome da linha do gráfico.
  • Valor: Valor do gráfico.
  • Meta: meta do mês.
  • Atingiu: Valor se atingiu.
  • Rótulo Atingiu: Rótulo da coluna se atingiu.
  • Rótulo Não Atingiu: Rótulo da coluna se não atingiu.
Formatação Condicional em Gráficos Excel 5

No gráfico nós temos então os valores destacados em vermelho quando passou a meta, em azul quando não atingiu e em cinza a meta para termos então a diferença do quanto passou da meta ou ficou aquém.

No vídeo ao topo aprenda como fazer e baixe no download a planilha pronta.

Mudar Gráfico ao Mudar de Linha – Formatação Condicional de Gráficos

Neste exemplo nós temos um gráfico que muda dinamicamente ao mudar de linha.

Formatação Condicional em Gráficos Excel 6

O gráfico usa para isso uma função Desloc aonde temos o deslocamento das linhas conforme a linha selecionada.

Para isso nós temos que mudar a linha selecionada verificando se a linha está entre a 17 e a 40 e se estiver muda na célula Q17 o número da linha que é utilizado na função desloc para mudar a linha.

A fórmula Desloc é esta: =DESLOC(B$17;$Q$17-17;)&” Acumulado “&TEXTO(O40;”R$ 0.00”)

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    If Target.Row > 17 And Target.Row < 40 Then
        Linha.Range("Q17").Value = Target.Row
    End If
End Sub

E o efeito é o que temos no gif no topo.

Faça o download do gráfico da planilha de exemplo no botão ao final do artigo e também pode assistir o vídeo

Download Planilha Formatação Condicional em Gráficos no Excel

Clique no botão abaixo para realizar o  download do arquivo de exemplo:

Baixe a planilha

Curso Excel Completo - Do Básico ao VBA

Quer aprender Excel do Básico, passando pela Avançado e chegando no VBA? Clique na imagem abaixo:


Marcos Rieper

Pai, marido, professor e consultor em Excel.

Obrigado por ler este artigo, este blog foi criado para difundir o conhecimento em Excel à todos.

Divulgamos novos artigos nas redes sociais, basta clicar nos ícones abaixo.

Excel não precisa ser complicado

Assine nossa newsletter e receba dicas práticas para dominar o excel