Classificarpor SortBy Excel – Classificar lista dinamicamente

Classificarpor SortBy Excel – Classificar lista dinamicamente

A função ClassificarPor é uma nova função que está sendo desenvolvida pela Microsoft para o Excel e permite que sejam realizadas classificações de dados dinamicamente com o Excel.

Esta é uma das novas funções de matrizes dinâmicas do Excel. Estas funções permitem são muito leves, práticas e rápidas.

A função SortBy se diferencia da função Classificar do Excel porque ela permite que sejam realizadas classificações dinâmicas por até 124 colunas diferentes e ainda de forma crescente ou decrescente.

Classificarpor sortby 4

Função ClassificarPor Excel

A função ClassificarPor retorna a classificação de uma tabela ou lista de dados automaticamente por mais de uma coluna de ordem.

Esta função se difere de várias outras formas de se fazer a classificação no Excel porque:

  1. É automática após qualquer inclusão, alteração ou exclusão de dados
  2. É muito rápida
  3. Trabalha com uma quantidade enorme de dados sem travar
  4. É muito fácil de aplicar
  5. Permite que sejam realizadas classificações por mais de uma coluna
  6. Classificação crescente ou decrescente para cada um dos índices de classificação

A função ClassificarPor, em inglês SortBy possui a seguinte sintaxe:

CLASSIFICARPOR(matriz;índice_de_classificação1;[ordem_de_classificação1];…)

  • matriz: Lista ou tabela de dados do Excel.
  • índice_de_classificação1: Seleção da coluna que será utilizada para a classificação.
  • ordem_de_classificação1: 1 ou -1. 1 para a ordem crescente e -1 para a ordem decrescente
  • : Podem ser adicionados até 124 índices de classificação e ordens de classificações.

Exemplo:

=CLASSIFICARPOR($A$7:$B$15;$A$7:$A$15;1)

Perceba que a lista em $A$7:$B$15 é classificada pela coluna $A$7:$A$15 de ordem crescente.

Classificação dinâmica de dados com matriciais

Para realizar a classificação dinâmica de dados, ou seja, ao alterar qualquer dado a classificação ser feita automaticamente é necessário atualmente utilizar fórmulas matriciais como no artigo: Classificar dados repetidos no Excel

Classificarpor sortby 2

A fórmula utilizada é: =ÍNDICE($A$7:$B$15;CORRESP(MENOR(($A$7:$A$15)*(1+(LIN($A$7:$A$15)/100000));LIN()-6);($A$7:$A$15)*(1+(LIN($A$7:$A$15)/100000));0);1).

Como pode notar é extremamente mais complicada do que o uso simples da função: =CLASSIFICARPOR($A$7:$B$15;$A$7:$A$15;1).

Download da planilha

Para o download do exemplo utilizado neste artigo preencha o seu nome e e-mail no formulário abaixo.

Baixe a planilha

Abraço

Marcos Rieper